Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль! Помогите пожалуйста!

5-9 класс

Дано целое число, больше 99. Найти третью от конца его цифру, последнюю цифру и разность квадратов этих цифр (использовать функции DIV и MOD).

Studentка 06 янв. 2017 г., 14:39:32 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lari1964
06 янв. 2017 г., 16:12:25 (7 лет назад)

var a,a1,a3,s: integer;
begin
read(a);
if a>99 then begin
a1:= a div 100 mod 10;
writeln (a1);
a3:= a mod 10;
writeln (a3);
s:=a1*a1-a3*a3;
writeln(s);
end;
end.

+ 0 -
Kea7419
06 янв. 2017 г., 18:57:31 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!

Нужно вписать истина или ложь))

для хранения файлов, предназначенных для общего доступа пользователей сети, используется:

а. файловый сервер
б. рабочая станция
в. клиент сервер
г. коммутатор

К реке одновременно подошли три купца и три разбойника.Всем необходимо было переправиться на противоположный берег.У берега стояла лодка,которая могла

вместить только двух человек.купцы боязливо поглядивали на разбойников,так как знали,что во время переправы может всякое случиться.Если во время переправы на берегу число разбойников и купцов будет одинаковым,то разбойники не тронут купцов;если же число разбойников привысит число купцов хотя бы на одного человека,то разбойники убьют купцов.перед купцами стояла сложная задача,но она была ими решена-все перебрались на тот берег,и жертв не было.Как сумели переправиться купцы и разбойники и сколько рейсов совершила лодка?За рейс следует считать движение лодки в одном направлении.

Читайте также

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!



Вы находитесь на странице вопроса "Паскаль! Помогите пожалуйста!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.