Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль: «Введите с клавиатуры число x. Определите, является ли данное число дробным.

5-9 класс

Пример ввода: 3.5
Пример вывода: Число дробное»

Dimaheylik 10 янв. 2017 г., 18:02:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kyza845
10 янв. 2017 г., 19:27:38 (7 лет назад)

Program z1;
var a,c:real;
begin 
readln(a); 
c:=round(a); 
if c=a then writeln('число не дробное')         
else writeln('Число дробное');  
end.

Ответить

Другие вопросы из категории

Паскаль! Помогите пожалуйста!

Дано целое число, больше 99. Найти третью от конца его цифру, последнюю цифру и разность квадратов этих цифр (использовать функции DIV и MOD).

Помогите пожалуйста!!!

Нужно вписать истина или ложь))

для хранения файлов, предназначенных для общего доступа пользователей сети, используется:

а. файловый сервер
б. рабочая станция
в. клиент сервер
г. коммутатор

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

Введите с клавиатуры число х. Определите , является ли данное число дробным

пример ввода 3.5
пример вывода
число дробное



Вы находитесь на странице вопроса "Паскаль: «Введите с клавиатуры число x. Определите, является ли данное число дробным.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.