Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите более короткие алгоритмы вычисления выражений : y=x в 15 степени, y=x в 19 степени

5-9 класс

Постарайтесь использовать минимальное количество дополнительных переменных.
Каждое выражение может содержать только одну арифметическаую операцию.

Dinarakochura 11 февр. 2017 г., 19:15:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AliskaIriska
11 февр. 2017 г., 21:38:21 (7 лет назад)

var x,y1,y2:real;
begin
read(x);
y1:= exp(ln(x)*15);
y2:= exp(ln(x)*19);
writeln(y1);
writeln(y2);
end.

Ответить

Читайте также

1) Как вы думаете, можно ли использовать в арифметическом выражении оператора присваивания неопределенную переменную? К каким последствиям это может

привести?

2) Напишите на АЯ алгоритм сложения двух простых дробей(без сокращения дроби)

3) Напишите на АЯ алгоритм вычисления Y по формуле: y=(1-x2+5x^4)^2, где x- заданное целое число. Учтите следующие ограничения: 1) В арифметических выражениях можно использовать только операции сложения, вычитания и умножения. 2) Выражение может содержать только одну арифметическую операцию. выполните трассировку алгоритма при x=2.

4) Пользуясь ограничениями предыдущей задачи, напишите наиболее короткие алгоритмы вычисления выражений: y=x^8, y=x^10, y=x^15, y=x^19. Выполните трассировку алгоритмов.

5) Запишите алгоритм циклического обмена значениями трех переменных A,B,C. Схема циклического обмена:

a-->b-->c(стрелочка C к A сверху)

Например, если до обмена было: A=1,B=2,C=3, то после обмена должно стать: A=3,B=1,C=2. Выполните трассировку.

напишите на АЯ алгоритм вычисления y по формуле ,где x-заданное число.Учтите следующие ограничения:1)в арифметических выражениях можно использовать только

опереции сложения,вычитания,и умножения;2)каждое выражение может содержать только одну арифметическую операцию.Выполните трассировку алгоритма при x=2

не используя функцию возведения в квадрат напишите на языке паскаль наиболее короткие алгоритмы вычисления: a) y=x в десятой b) y= x в пятнадцатой

Постараться использовать минимальное количество дополнительных переменных.

Помогите пожалуйста, заранее спасибо Не используя функцию возведения в квадрат, напишите на

языке Паскаль наиболее короткие алгоритмы вычисления:

а) y=x10 б) y=x15

Постараться использовать минимальное количество дополнительных переменных.



Вы находитесь на странице вопроса "Напишите более короткие алгоритмы вычисления выражений : y=x в 15 степени, y=x в 19 степени", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.