Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

N-Factorial это произведение всех чисел от 1 до N. Для задного числа N определите сколько нулей в конце десятичной записи N-Factorial .

10-11 класс

В единственной строке входного файла содержится одно целое положительное числа NN(1

яриклицеист 18 мая 2014 г., 12:36:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dimushka
18 мая 2014 г., 13:23:49 (10 лет назад)

Сначала банальный код - рабочий, но уже на больших числах будет переполнение переменной факториала.
var n, i, fact, ans : integer;
begin
  read(n);
  fact := 1;
  for i := 2 to n do
    fact := fact * i;
  while (fact mod 10 = 0) do begin
    ans := ans + 1;
    fact := fact div 10;
  end;
  writeln(ans);
end.


Теперь более "умный" код, в нём использован тот факт, что простое число p входит в разложение факториала числа N = [N/p] + [N/p^2] + [N/p^3] + ..., где [x] - целая часть числа x.
var n, i, fact, c, pow, ans : integer;
{c - сколько раз входит в разложение числа n! цифра 5}
begin
  read(n);
  pow := 5;
  while (pow <= n) do begin
    c += n div pow;
    pow := pow * 5;
  end;
  writeln(c);
end.

Ответить

Читайте также

Задача А Четные

N-Factorial - это произведение всех чисел от 1 до N.Для заданного числа N определите,сколько нулей в конце десятичной записи.
Формат входных данных

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99



Вы находитесь на странице вопроса "N-Factorial это произведение всех чисел от 1 до N. Для задного числа N определите сколько нулей в конце десятичной записи N-Factorial .", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.