Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПОМОГИТЕ ПЛИИИЗ!!!!

10-11 класс

Даны 3 действительных числа. Возвести в квадрат и напечатать те из них, значения которых неотрицательны. Если таковых нет, то напечатать сообщение.
С++

золотковчик 02 окт. 2013 г., 20:25:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Strichmogy
02 окт. 2013 г., 20:58:12 (10 лет назад)

using namespace std;

int main ()
{
SetConsoleOutputCP(1251);
cout<<"Введите три числа"<<endl;
int a,b,c;
cin>>a>>b>>c;
if ( (a<0) && (b<0) && (c<0))
   {
   cout<<"неотрицательных чисел нет"<<endl;
   system("pause");
   return 0; // дальше не выполняем, чтобы не тратить силы впустую
   }
if (a>0)
   cout<<a*a<<endl;
if (b>0)
   cout<<b*b<<endl;
if (c>0)
   cout<<c*c<<endl;
system("pause");
return 0;
}

Ответить

Другие вопросы из категории

Вот фрагмент таблицы результатов тестирования:

Фамилия Пол Матема¬тика Русский язык Хи¬мия Инфор¬матика Биоло¬гия
Аганян ж 82 56 46 32 70
Воронин м 43 62 45 74 23
Григорчук м 54 74 68 75 83
Роднина ж 71 63 56 82 79
Сергеенко ж 33 25 74 38 46
Черепанова ж 18 92 83 28 61
Сколько записей в этом фрагменте удовлетворяют условию
«Пол='ж' ИЛИ Математика + Информатика >120»?

паскаль 1)

Составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем.
2)
Составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). Число n, первый элемент и разность прогрессии вводятся пользователем. Вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.

отметьте правильные ip адреса

a)192.168.1.1
b)12.23.1
c)272.23.34.31
d)1.12.256.1
e)192.168.0.257

Читайте также

Помогите плиииз=)

Привет. Помогите плиз=)
№1)Составить алгоритм вывода среднего(не арифметического) из трёх чисел в виде блок-схемы.
Входные данные:три числа
Выходные данные:среднее число

№2) На вход подаётся число. Нужно вывести числа от данного до 10. Если оно изначально больше 10, завершить программу.

помогите плиииз=))) у меня есть программа но вней 2 ошибки нужно сделать с помощью динамического массива... // laba4_2.cpp : Defines the entry

point for the console application.
//

#include "stdafx.h"
#include "stdio.h"
//#include "math.h"

using namespace std;


int main ( )
{
float *a;
int i,n;
printf("n=");
scanf("%i",&n);
a=(float*)malloc(N*sizeof(float));
for( i=0; i<=n-1;i++ )
{
printf("a[%i]= ",i );
scanf("%i",&a[i]);
}
for (i=0; i<=N-1; i++)
{
if (a[i]<0)
{
printf("oshibka\n");
}
else
{
if (a[i]/2==0)
{
printf("chetnoe \n");
}
else
{
printf("nechetnoe\n");
}
}

}

return 1;
}

Помогите плиииз)))


Вы находитесь на странице вопроса "ПОМОГИТЕ ПЛИИИЗ!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.