Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите!

5-9 класс

Нужно написать программу в Паскале.
Нужно найти мах и мин в массиве и поменять их местами!

Lfybk09 07 февр. 2015 г., 20:43:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Виолетточка1997
07 февр. 2015 г., 21:18:05 (9 лет назад)

var a:array[0..100] of integer;
i:integer;
max,min:integer;
begin
  for i:=0 to 100 do begin
    if a[i]<a[min] then min:=i;
    if a[i]>a[max] then max:=i;
  end
  i:=a[max];
  a[max]:=a[min];
  a[min]:=i;
end.

Ответить

Другие вопросы из категории

Женя готовил доклад по литературе. В докладе 12 строчек,в каждой строчке 22 символа.Определить количество информации,если а)в 1 символе 10 разрядов

двоичного кода б) в алфавите 115 букв в) в алфавите 128 букв г) в алфавите 125 букв

Исполнитель Черепашка ползет по клеткам бесконечной вертикальной клетчатой доски, переходя по одной из команд:

вверх, вниз, вправо, влево -

в соседнюю клетку в указанном направлении.



Черепашка выполнила следующую программу:

вправо вниз вправо вверх влево вверх вверх влево,



в результате которой перешла из клетки а в клетку b. Укажите наименьшее
возможное число команд в программе, переводящей Черепашку из начальной
клетки а в конечную клетку b.

1.

средняя скорость письма ученика составляет 20 слов в минуту 1 слово в среднем 7 символов 1 символ имеет информационный обьем 5 битов Какое количество

информации может записать ученик за 1 час непрерывного письма (ответ в байтах)

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

после установки виндовс 7 у меня не работают колонки компьютер их не видит помогите.

если пофессионал помогите в двойне плиз !!!!

Помогите эти задания зависят на оценку за четверть 1) Записать алгоритм распознания среди всех треугольников прямоугольные, если таковых нет

вычислить периметр.

2) Последовательно вводится N целых чисел найти кол-во равных нулю.

помогите очень нужно!



Вы находитесь на странице вопроса "Помогите!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.