Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста очень прошу вас добрые вы люди .-. Даны три числа a,b,c если они положительные то найти их сумму,а если отрицательные то поменять

5-9 класс

знаки и затем найти сумму Помогите алгоритм составить в Паскале .

Karinka1998 20 окт. 2014 г., 5:46:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Veselovka47
20 окт. 2014 г., 8:43:59 (9 лет назад)

programm New1;

var a, b, c:integer;

begin
Writeln ('Ввод а,b,c,sum');

Readln (a,b,c);

if a<0 then a:=-a;

if b<0 then b:=-b;

if c<0 then c:=-c;

sum:=a+b+c;

Writeln (sum);

readln;

end.

Ответить

Другие вопросы из категории

Коля задумывает натуральное число из отрезка от 1 до N. Петя должен это число отгадать. Он может задавать Коле вопросы, допускающие только ответы "Да" или

"нет". Петя разработал алгоритм, позволяющий за наименьшее число вопросов отгадать число задуманное Колей.
Вопрос:
Сколько вопросов потребуется Пете, чтобы отгадать задуманное Колей число, если оно принадлежит отрезку:
1)от 1 до 32
2)от 1 до 512
3)от 1 до 300
4)от 1 до 1024

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Помогите пожалуйста,очень срочно!

Ввести три числа,вывести на экран их сумму,произведение и среднее арифметическое.

(В паскале,по такому типу:
Var
Begin
WriteLn
End)
Буду очень благодарна!

Два солдата подошли к реке, по которой на лодке катаются двое детей перевозчика.Опишите алгоритм,как солдатам переправится на другой берег, если лодка

вмещает только одного солдата(либо двоих детей),а солдата и ребенка уже не вмещает?помогите пожалуйста очень прошу на завтра задали

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,



Вы находитесь на странице вопроса "Помогите пожалуйста очень прошу вас добрые вы люди .-. Даны три числа a,b,c если они положительные то найти их сумму,а если отрицательные то поменять", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.