Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Ребята, пожалуйста помогите!! Нужно написать программы к четырём задачам на паскале.

10-11 класс

4) Ввести однородный массив A из N элементов. Отрицательные элементы массива умножить на квадрат собственного индекса. Массив вывести до и после преобразования.

АйгизAigiz 21 авг. 2016 г., 14:50:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
двчушка
21 авг. 2016 г., 16:50:43 (7 лет назад)

Задача №4
var
  n, i, mn, mx:integer;
  a:array [1..10] of integer;
begin
  writeln('Vvedite n (<=10):');
  readln(n);
  writeln('Vvedite massiv');
  for i:=1 to n do
  readln(a[i]);
  writeln('Ishodnii massiv');
  for i:=1 to n do
  write(a[i],' ');
  writeln();
  for i:=1 to n do
  if a[i]<0 then a[i]:=a[i]*sqr(i);
  writeln('Massiv posle obrabotki');
  for i:=1 to n do
  write(a[i],' ');
  writeln();
  readln();  
end.

+ 0 -
Dashagerasimen
21 авг. 2016 г., 17:32:43 (7 лет назад)

uses crt; const n=10; var a: array [1..n] of integer;     i: integer; begin writeln('Дан массив'); for i:=1 to n do     begin     a[i]:=random(19)-9;     write(a[i]:5);     end; writeln; writeln('Преобразованный массив'); for i:=1 to n do     begin     if a[i]<0 then a[i]:=a[i]*i*i;     write(a[i]:5);     end; end.

+ 0 -
Milanastepanov
21 авг. 2016 г., 18:56:53 (7 лет назад)

Ребята, а на изображении как решать знает кто нибудь? помогите :(

Ответить

Другие вопросы из категории

Помогите решить в Pascal:1)Даны коэффициенты прямой y=kx+b.Найти координаты ее пересечения с линией y=x.2)Даны координаты концов двух

отрезков.Пересекаются ли они(пересекающимися мы будем называть фигуры,имеющие хотя бы однуобщую точку)

вывести на экран среднее значение суммы 10 чисел

создать программу нахождения максимального среди n чисел

пользователь работал с каталогом В:/фотографии/дом/кошка. сначала он поднялся на два уровня вверх, потом спустился в каталог экзамены после этого

спустился в каталог сочинение. Запишите пооный путь каталога, в котором оказался пользователь. 1. D:/Сочинение/экзамен 2.D:/экзамен/сочинение 3. D:/фотографии/экзамен/сочинение 4. D:/фотографии/сочинение/экзамен

Читайте также

Задание Определить, изделия какой из двух групп товаров выгоднее сшить из одного рулона ткани, если известны: расход ткани на каждое изделие и цена

готового изделия, количество метров в рулоне. Помогите, нужно написать программу решения этой задачи в Паскале

Прошу вас помогите!Нужно написать программу,но только обязательно в Visual Basic!!!!!

На вход программе подаются сведения о
телефонах всех сотрудников некоторого учреждения. В первой строке
сообщается количество сотрудников N, каждая из следующих N строк имеет
следующий формат:

<Фамилия> <Инициалы> <телефон>

где <Фамилия> – строка, состоящая не более чем из 20 символов, <Инициалы> - строка, состоящая не более чем из 4-х символов (буква, точка, буква, точка), <телефон> – семизначный номер, 3-я и 4, я, а также 5-я и 6-я цифры которого разделены символом «–». <Фамилия> и <Инициалы>, а также <Инициалы <телефон> разделены одним пробелом. Пример входной строки:

Иванов П.С. 555-66-77

Сотрудники
одного подразделения имеют один и тот же номер телефона. Номера
телефонов в учреждении отличаются только двумя последними цифрами.
Требуется написать как можно более эффективную программу, которая будет
выводить на экран информацию, сколько в среднем сотрудников работает в
одном подразделении данного учреждения.


Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.



Вы находитесь на странице вопроса "Ребята, пожалуйста помогите!! Нужно написать программы к четырём задачам на паскале.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.