Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста составить на Паскале программу полного решения БИКВАДРАТНОГО уравнения. Заранее спасибо.

10-11 класс

Daaaaaaaaaaaaaa 03 авг. 2014 г., 20:09:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Psycho1997
03 авг. 2014 г., 20:56:37 (9 лет назад)

program kvad;
var a,b,c:real;
x1,x2, d:real;
begin
writeln('Введите 3 аргумента');
write('a = ');
readln(a);
write('b = ');
readln(b);
write('c = ');
readln(c);
d := sqr(b) - 4 * a *c;
if (d > 0 ) then   
begin   
     writeln('x1 = ', -b + sqrt(d) / 2*a);       
     writeln('x2 = ', -b - sqrt(d) / 2*a);   
end
else if (d = 0) then     
     writeln('x = ', - b / 2*a)
else    writeln('Решений не существует!!');
end.

Ответить

Другие вопросы из категории

Вася придумал игру,в которой герой должен добраться до финиша,прыгая по платформам. Прыжок может быть на соседнюю платформу или через одну платформу. В

первом случае затрачивается |x2-x1|, а во втором 3*|x2-x1| единиц энергии, где х1 и х2-высоты платформ, с которой и на которую совершается прыжок.Какое минимальное количество энергии герой потратит, что перебраться на конечную платформу начав с первой.
Помогите пожалуйста:(

Самая распространенная на сегодняшний день технология локальных сетей:

1) Token Ring

2) Ethernet )) a, o

3) 100VG-AnyLAN

4) FDDI

помогите, пожалуцста, ребят
решить в паскаль abc

оператор выбора case.
В библиотеке в книжном шкафу 10 полок, на каждой из них разная литература: 1 – математика; 2 – физика; 3 – химия; 4 – программирование; 5 – русский язык; 6 – литература для чтения; 7-10 – пустые полки. Напишите программу, которая выводит сообщение, о том какие книги находятся на данной полке. В случае если введено число больше 10, выводится сообщение «Полки с таким номером нет».

Преобразовать

число 300000 к нормализованному виду

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста)

Нужно составить в паскале программу для проверки пароля, совсем не понимаю паскаль, для меня это темный лес!)

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите человеку с отвратительной фантазией 1. Составить задание на разработку программы линейной структуры в QBASIC

2. Составить задание на разработку программы на разветвляющиеся структуры в QBASIC

3. Составить задание на разработку программы циклической структуры в QBASIC

Нужно задание + сама программа



Вы находитесь на странице вопроса "Помогите пожалуйста составить на Паскале программу полного решения БИКВАДРАТНОГО уравнения. Заранее спасибо.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.