Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В Паскаль АВС создать интересное изображение средней сложности.(помогите плиз!)

10-11 класс

Hdhdjdjdj 21 сент. 2014 г., 20:44:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Owsukova18
21 сент. 2014 г., 21:22:49 (9 лет назад)

uses
  GraphABC;
var
  i, k: integer;
  arr: array [1..6] of color;
begin
  writeln('Сколько кирпичиков?');
  readln(k);
  arr[1] := clPink; arr[2] := clRed; arr[3] := clGreen;
  arr[4] := clBlue; arr[5] := clYellow; arr[6] := clOrange;
  for i := 0 to k - 1 do
  begin
    SetBrushColor(arr[random(6) + 1]);
    FillRectangle((i mod 16) * 40, (i div 16) * 20, (i mod 16) * 40 + 39, (i div 16) * 20 + 19);
    sleep(20);
  end;
end.

Стена из кирпичиков - норм?)

Ответить

Другие вопросы из категории

Гражданин Петров взял в долг у своего

приятеля Сидорова 9800р., выдав
последнему вексель, по которому
обязался выплатить 10000р. через 3
месяца. Под какой долговой процент
выдан вексель?

Вася придумал игру,в которой герой должен добраться до финиша,прыгая по платформам. Прыжок может быть на соседнюю платформу или через одну платформу. В

первом случае затрачивается |x2-x1|, а во втором 3*|x2-x1| единиц энергии, где х1 и х2-высоты платформ, с которой и на которую совершается прыжок.Какое минимальное количество энергии герой потратит, что перебраться на конечную платформу начав с первой.
Помогите пожалуйста:(

Самая распространенная на сегодняшний день технология локальных сетей:

1) Token Ring

2) Ethernet )) a, o

3) 100VG-AnyLAN

4) FDDI

Читайте также

ПАСКАЛЬ АВС

ОЧЕНЬ СРОЧНО,ПОЖАЛУЙСТА


При помощи функции trunc() в Паскале можно реализовать операции целочисленного деления и взятия остатка от деления. Например:
целочисленное деление - trunc(491/240) - результатом будет 2;
остаток от деления - 491-240*trunc(491/240) - результатом будет 11.
Используя функцию trunc(), напишите программу, считающую сдачу в английской денежной системе (в этой денежной системе 1 фунт стерлингов равен 20 шиллингам, а 1 шиллинг равен 12 пенсам). Напишите программу, в которой в трёх константах хранится стоимость товара. Одна константа - фунты (целое значение больше нуля), вторая - шиллинги (значение от 0 до 19), третья - пенсы (значение от 0 до 11). Ещё в трёх таких же константах хранится плата покупателя. Используя одну целочисленную переменную, программа должна сосчитать и вывести на экран сдачу в фунтах, шиллингах и пенсах. НЕ ИСПОЛЬЗОВАТЬ УСЛОВНЫЙ ОПЕРАТОР

ПРОГРАММА ДОЛЖНА БЫТЬ НАПИСАНА НА ПАСКАЛЕ АВС

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Нужно сделать в паскаль АВС Самолет летит из пункта А в пункт Б со средней скоростью V. Составить программу для

нахождения времени полёта t1, если есть встречный ветер, скорость которого V1, и времени t2, если ветра нет. Расстояние между пунктами A и Б считать известным и равным S.



Вы находитесь на странице вопроса "В Паскаль АВС создать интересное изображение средней сложности.(помогите плиз!)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.