Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогиитее решить задачку по информатике!(( В заданном массиве A(N), все элементы которого попарно различны, найдите:

10-11 класс

а) наибольший элемент из отрицательных;

Sasha1606 15 февр. 2017 г., 14:55:20 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jekacross94
15 февр. 2017 г., 15:36:57 (7 лет назад)

с в) долго думал

 

#include <stdio.h>
#include <stdlib.h>
#include <conio.h>
#include <iostream>
using namespace std;
int main(int argc, char* argv[])
{
int arr[10];
cout << "input elements " << endl;
for ( int i= 0; i < 10; i++ )
cin >> arr[i];
int max=-9999;
int min=9999;
cout << "Massiv " << endl;
for ( int o= 0; o < 10; o++ )
cout << arr[o] <<" ";
cout << ""<<endl;
for ( int l= 0; l < 10; l++ )
if((arr[l]>max) and (arr[l]<0 ) )
max =arr[l];

cout << "Max from negatives is: " <<" ";
cout << max << endl;
for ( int z= 0; z < 10; z++ )
if((arr[z]<min)and(arr[z]>=0)) min =arr[z];
cout << "Min from positives is: " <<" ";
cout << min << endl;

int gmax,gmax2;
gmax=arr[1];
gmax2=arr[2];
for (int l=2;l<10;l++)
if(arr[l]>gmax){
gmax2=gmax;gmax=arr[l]; }else if(arr[l]>gmax2)gmax2=arr[l];
cout << "Second greatest element is: " <<" ";
cout << gmax2<< endl;
}

Ответить

Другие вопросы из категории

Помогите пожалуйста срочно надо ?

1 Кбайт=.........байт = ........ бит
7 Кбайт=......... байт = ........ бит
15 Кбайт =........байт = ......бит

Найти формулу данной функции

Читайте также

Помогите, пожалуйста, решить задачку по информатике. Pascal ABC. 10 класс.

Зарание огромное спасибо))

Помогите, пожалуйста, решить задачу по информатике)

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду­щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите, пожалуйста, решить задачу по информатике (с объяснениями): Задача 3. Экранная клавиатура КПК позволяет вводить символы русского

и английского алфавита прикосновением пера к экрану. Для переключения между заглавными и строчными буквами используется клавиша Shift, нажатие на которую приводит к смене режима на время ввода одной следующей буквы, и клавиша Caps Lock для постоянной смены режима. Для смены алфавита с русского языка на английский используется клавиша au (клавиша находится между Ctrl и Alt). В начальном состоянии клавиатура находится в режиме строчных русских букв.

Требуется написать программу, выводящую минимальную длину

последовательности прикосновений пера для набора заданной строки.

Технические требования.

Имя входного файла: INPUT.TXT

Имя выходного файла: OUTPUT.TXT

Формат входных данных:

В единственной строке входного файла содержится строка длиной не более 50 скатолов, содержащая заглавные и строчные русские и английские буквы. Формат выходных данных:

В единственной строке выходного файла содержится единственное число - минимальная длина последовательности прикосновений пера для набора заданной строки.

Примеры файлов входных данных: Примеры файлов выходных данных:

Строка 7

ПРИВЕТhеllо 14



Вы находитесь на странице вопроса "Помогиитее решить задачку по информатике!(( В заданном массиве A(N), все элементы которого попарно различны, найдите:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.