Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано количество секунд сначала суток. Вычислить текущее время в виде количества часов, минут и секунд.

5-9 класс

вво 13 июня 2013 г., 22:40:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natalikatashuk
14 июня 2013 г., 1:15:37 (10 лет назад)

var h,m,s,a: integer;
begin
readln(a);
h:= a div  3600;
m:= (a - h*3600) div 60;
s:= a - m*60 - h*3600;
writeln(h); writeln(m);write(s);
end.

+ 0 -
Виктория123456789123
14 июня 2013 г., 2:19:40 (10 лет назад)

uses crt;
var a,h,m,s:integer;
begin
readln(a);
h:=a div 3600;
a:=a mod 3600;
m:=a div 60;
a:=a mod 60;
s:=a;
write(h,':',m,':',s);
end.

Ответить

Другие вопросы из категории

Известно, что X, Y и Z – произвольные числа. Запишите в виде логического выражения следующие составные высказывания: 1) "Все числа X и Y, и Z –

отрицательные"; 2) "Число X – отрицательное, а Y и Z положительные."; 3) "Y - минимальное число среди чисел X, Y, Z ." *
Например, высказывание "Хотя бы одно число положительное" формально выглядит так:"(x>0) v (y>0) v (z>0)".

Читайте также

помогите пожайлуста))))))))))) Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из

моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.

ввод:1, 1, 1, 2, 2, 2

вывод: 3661

ввод:1,2,30,1,3,20

вывод: 50

это задача на pascal ABC

Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из моментов времени. Известно, что

второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.

Пожалуйста, решите 2 задачи в паскаль. Очень прошу!!!

1)Дано количество секунд, прошедших с начала суток. Сколько полных часов прошло с начала суток, сколько минут прошло с начала очередного часа и сколько секунд прошло с начала очередной минуты?
2)Сколько квадратов со стороной а поместится в прямоугольнике со сторонами x и y? Вычислите незаполненную площадь

Написать программу,которая вычисляет сумму первых n членов ряда 1,3,5,7. Количество суммируемых членов ряда задаётся во время роботы программы.

(ниже представлен рекомендуемый вид экрана во время работы программы)
Вычисление частичной суммы рада 1,3,5,7.
Введите количество суммируемых членов ряда: 15
Сумма первых 15 членов ряда равна 330.

Ребята,помогите пожалуйста!!!))) суть задания: Составьте блок-схему и программу на языке VBA, которая вычисляет сумму первых n целых положительных четных

чисел. Количество суммируемых
чисел должно вводиться во время работы программы. Программа должна
проверять правильность введенных пользователем данных и, если они неверные ( n ≤ 0 ), выдавать сообщение об ошибке.
Буду очень признательна, если кто-нибудь возьмется за это задание. Спасибо)



Вы находитесь на странице вопроса "Дано количество секунд сначала суток. Вычислить текущее время в виде количества часов, минут и секунд.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.