Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано 80 вещественных чисел. Найти порядковый номер того из них, которое наиболее близко к какому-нибудь целому числу.

10-11 класс

Помогите решить пожалуйста

Argentina7 12 февр. 2014 г., 13:35:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vmurgin2012
12 февр. 2014 г., 15:54:50 (10 лет назад)

var
  a: array [1..80] of real;
  n: byte := 1;

begin
  for i: integer := 1 to 80 do
  begin
    a[i] := trunc(random() * 100) / 100;
    write(a[i], ' ');
  end;
  for i: integer := 1 to 80 do
    if (abs(a[i] - round(a[i])) < abs(a[n] - round(a[n]))) then
      n := i;
  writeln();
  writeln(n);
end.

Ответить

Другие вопросы из категории

Леголас хочет поразить из лука максимальное количество из десяти мишеней, обозначенных цифрами от 0 до 9. При этом он не хочет, чтобы сумма номеров

двух пораженных подряд мишеней составляла несчастливое для эльфов число 6 или более. Какую по номеру мишень Леголас может поразить последней, если первая его стрела полетела в мишень с номером 0?

сколько бит содержит 3 Кбайт?

Читайте также

Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из

чисел ai,. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. Если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Дана последовательность

не более N
ненулевых целых чисел, последним числом в последовательности является
0. Ввести эту последовательность в одномерный массив и
вычислить хаpактеристики
.Найти порядковые номера и сумму двух наибольших элементов. ( в Паскаль )



Вы находитесь на странице вопроса "Дано 80 вещественных чисел. Найти порядковый номер того из них, которое наиболее близко к какому-нибудь целому числу.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.