Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить в C++

10-11 класс

Дана последовательность из n целых чисел. Найти количество элементов этой последовательности, кратных числу К.

Jasonmilestm 19 нояб. 2013 г., 18:27:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Лиля160197
19 нояб. 2013 г., 20:45:32 (10 лет назад)

#include <iostream>

int main()
{
    int n, k, amount = 0;
    std::cin >> n;                  //!Вводится число n
    int array[n];
    for(int i = 0; i < n; ++i)      //!Вводятся числа последовательности
        std::cin >> array[i];
    std::cin >> k;                   //!Вводится k
    for(int i = 0; i < n; ++i)
        if(!(array[i] % k))
            amount++;
    std::cout << amount;
    return 0;
}

+ 0 -
Dashakisel2
19 нояб. 2013 г., 22:58:09 (10 лет назад)

Может быть не рациональное решение
#include <iostream>
using namespace std;

+ 0 -
Кариин
20 нояб. 2013 г., 0:15:33 (10 лет назад)

Где вводится К? Перед или после последовательности?

+ 0 -
IamSasha
20 нояб. 2013 г., 3:12:52 (10 лет назад)

Об этом не сказано.

+ 0 -
Murmurchik
20 нояб. 2013 г., 4:20:21 (10 лет назад)

Судя по формулировке задачи, К дано в конце

+ 0 -
Oksanametla
20 нояб. 2013 г., 5:47:37 (10 лет назад)

int crat(a[], n, k){ int rez=0; for(int i; i < n; i++) if(a[i]%k == 0) rez++;return rez;}

+ 0 -
Гафурова2013
20 нояб. 2013 г., 7:24:22 (10 лет назад)

примерно так должно быть

Ответить

Другие вопросы из категории

Удвоить трѐхзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае.

Если введѐнное число не трѐхзначное, вывести сообщение об ошибке.(В ПАСКАЛЕ)

Мне нужен рисунок для pascal ABС,рисунок должен быть большой.

Только не граффический!

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

Помогите решить две задачки (Паскаль)

Задание 1
В одномерном массиве случайных вещественных числе F(17) определить количество положительных элементов и их сумму.

Задание 2
В матрице L(5,5) случайных вещественных чисел определить максимальный элемент выше побочной диагонали, поменять его местами с элементом 2 строки 2 столбца.

Большая просьба расписать задачу подробно , хочу не просто списать решения , а понять его и научиться решать сам , огромное спасибо.

Здравствуйте, прошу помогите решить такое вот чудо.

Решить вроде бы нужно найти что за число вместо x.
Кто знает как правильнее прошу вашей помощи.
Чтобы просмотреть фото, кликните на него.



Вы находитесь на странице вопроса "Помогите решить в C++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.