Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

среди всех натуральных четырехзначных чисел подсчитать количество таких, сумма квадратов цифр, которых кратна двум или трем. Ответ дайте целым числом

5-9 класс

Katya83 16 апр. 2015 г., 16:01:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gaizula28
16 апр. 2015 г., 16:59:12 (9 лет назад)

var
    i, s, k, n: integer;

begin
    for i := 1000 to 9999 do begin
        n := i;
        s := 0;
        while n > 0 do begin
            s := s + (n mod 10) * (n mod 10);
            n := n div 10;
        end;
        if (s mod 2 = 0) or (s mod 3 = 0) then begin
            k := k + 1;
            writeln(i, ' ', s);
        end;
    end;
    writeln(k);
   
end.

Ответить

Другие вопросы из категории

Скорость чтения ученика 6 класса составляет приблизительно 160 симфолов в минуту. Какой объем информации получит ученик, если он будет читать в течение

30 минут?

Сколько времени потребуется ученику, чтобы прочесть, текстовый файл, занимающий половину трех дюймовой дискеты?

№1. Сколько мегабайт информации содержаться в сообщении объемом 2^27 бит? №2.Средняя скорость передачи данных с помощью модема равна 61440 бит/сек.

Определить объем информации в Кбайт,если время передачи 16 сек.

№7.Как десятичное число 123 будет представлено в двоичной системе счисления?

алгоритм рисования цифры 9
¢Типы подпрограмм.
Перевести в байты:

1,3 Гбайта. 512 бит. 400 бит. 13 Гбайт. 0,9 Мбайт.
Перевести в биты:
52 Кбит. 24 Мбайта, 40 Гбайт. 18 Мбайт. 24 Мбайт. 184 Кбит. 0,5 Гбайт.
Какое кол-во килобайт содержится в 28672 битах?
Какое кол-во байт содержится в 1/4 килобайта?
Какое кол-во байт содержится в 2,5 Мбайт?

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход

программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет

Напишите программу, которая в последовательность натуральных чисел определит значение наибольшего из всех нечетных введеный чисел. Программа

получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входят в последовательность) .

Количество чисел не привышает 1000. Введеные числа не привышают 30000.

Программа должна вывести одно число - наибольшее из всех нечеиных введеных чисел.

Пример работы программы:

Входные данные Выходные данные

15 17

20

17

0



Вы находитесь на странице вопроса "среди всех натуральных четырехзначных чисел подсчитать количество таких, сумма квадратов цифр, которых кратна двум или трем. Ответ дайте целым числом", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.