Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напечатать заданный текст с удалением из него всех букв b, непосредственно перед которыми находится буква с.

10-11 класс

Slavakrasava 06 февр. 2014 г., 17:03:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sivva2004
06 февр. 2014 г., 18:54:12 (10 лет назад)

var
  s: string;
  i: integer;
begin
  readln(s);
  i := 1;
  while (i < length(s)) do
  begin
    if ((s[i] = 'b') and (s[i + 1] = 'c')) then
      delete(s, i, 1);
    i := i + 1;
  end;
  writeln(s);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста)

16 вопрос)
Буду очень благодарен)

Задание 4. Студентам была предложена анкета о том, знание каких из прочитанных

курсов могут потребоваться в будущей работе. Результаты анкетирования были
занесены в файл. Напишите программу создания файла анкетирования. Список
прочитанных курсов:

Шифр Виженера. Это шифр Цезаря с переменной величиной сдвига. Величину сдвига задают ключевым словом. Например,ключевое слово ВАЗА означает следующую после

довательность сдвигов букв исходного текста : 3 1 9 1 3 1 9 1 и т.д
Используя в качестве ключевого слово ЗИМА,закодировать слова : АЛГОРИТМИЗАЦИЯ,КОМПЬЮТЕР,ИНТЕРНЕТ

Помогите пожалуйста !!!!!

Читайте также

Задание #1

Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.

Задание #2
Напиши программу, вычисляющую стоимость покупки с учетом 10 %-й скидки, которая предоставляется только в том случае, если сумма покупки больше 1000 рублей.

Задание #3
Напиши программу, вычисляющую сумму всех четных чисел от 1 до N.

Задание #4
Напиши программу, вычисляющую среднее арифметическое заранее созданного массива случайных чисел из 10 элементов.

Наташа набрала текст на компьютере. Текст получился на 12 страниц, каждая страница состоит из 24 строк, в каждой строчке 21 символ. Определите

информационный объём получившегося текста в одной из кодировок Unicode? в которой каждый символ кодируется 16 битами.
А)12, 4Кбайт
В)16,1Кбайт
С)300Кбайт
D)1024Кбайт

Pascal

1)Задан список из 7 фамилий. Определить, имеется ли в списке фамилия, начинающаяся с буквы "А" и состоящая из 6 букв. Если да, то вывести ее на экран
2)В заданном тексте удалить символ ' , ' и подсчитать число удаленных символов. Предусмотреть возможность задания с клавиатуры удаляемого символа.
3)Организовать простейшую базу данных по студентам группы. Сведения о студенте включают: ФИО, год рождения, пол, средний балл. Обеспечить ввод данных, редактирование, вывод на экран. Информацию хранить в типизированном файле.
Помогите пожалуйста решить. отдаю полностью все свои баллы

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ -20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.
Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).
Поменять местами первый положительный и последний отрицательный элементы.

Один из часто встречающихся видов списка стек — список, в котором все операции включения и извлечения, сопровождающегося удалением из списка, элементов

выполняются только с одного края. Механизм функционирования стека отражён в его названии «LIFO» (Last In First Out — последним вошёл, первым вышел, подобно патронам в обойме). Следовательно, любой элемент не может быть извлечён и удалён из стека раньше, чем будут извлечены все элементы, помещённые в стек позднее него. Составить программу, реализующую функционирование стека. Стек оформить как массив.



Вы находитесь на странице вопроса "Напечатать заданный текст с удалением из него всех букв b, непосредственно перед которыми находится буква с.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.