Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

у исполнителя делитель две команды которым присвоены номера:

5-9 класс

раздели на 2
вычти 3

1xJUKx1 22 марта 2017 г., 12:32:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Adriano999
22 марта 2017 г., 13:38:34 (7 лет назад)

var a,b:integer;
begin
readln(a,b);
while a<>b do begin
if (a mod 2=0)and(b*2<=a)then begin
a:=a div 2;
writeln(':2');
end
else
begin
a:=a-2;
writeln('-2'); end;
end;
end.

Ответить

Другие вопросы из категории

Задача 1 Определить кол-во цифр в числе .

Задача 2 Напечатать те натуральные числа квадрат которых не превышает n .
Задача 3 Найти первое натуральное число куб которого больше n .

Читайте также

У исполнителя Делитель две команды, которым присвоены номера:

1. раздели на 2
2. вычти 1
Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 1.
Исполнитель работает только с натуральными числами.
Составьте алгоритм получения из числа 65 числа 4, содержащий не более 5 команд. В ответе запишите только номера команд.
(Например, 12112 – это алгоритм:
раздели на 2
вычти 1
раздели на 2
раздели на 2
вычти 1,
который преобразует число 42 в число 4).
Если таких алгоритмов более одного, то запишите любой из них.

1)У исполнителя УТРОИТЕЛЬ две команды, которым присвоены номера:

1. вычти 1
2. умножь на 3
Первая из них уменьшает число на экране на 1, вторая – увеличивает его в три раза.Запишите порядок команд в программе получения из числа 3 числа 16, содержащей не более 5 команд, указывая лишь номера команд.(Например, программа 21211 это программа,которая преобразует число 1 в 4
умножь на 3
вычти 1
умножь на 3
вычти 1
вычти 1
2)Исполнитель робот ходит по клеткам бесконечной вертикальной клетчатой доски,переходя по одной из команд вверх,вниз,вправо,влево в соседнюю клетку в указанном направлении.
вправо
вверх
влево
влево
вниз
вниз
вправо
вправо
вправо
вниз
влево
Укажите наименьше взможное число команд в программе,переводящей Робота из той же начальной клетки

ПОМОГИТЕ ХОТЬ ЧТО МОЖИТЕ ОЧЕНЬ ПРОШУ 1. У исполнителя Калькулятор две команды, которым присвоены номера: 1. прибавь 2 , 2. умножь на 3

Первая из них увеличивает число на экране на 2, вторая – утраивает его. Запишите порядок команд в алгоритме получения из числа 0 числа 28, содержащем не более 6 команд, указывая лишь номера команд (например, программа 21211 это программа умножь на 3 прибавь 2 умножь на 3 прибавь 2 прибавь 2 которая преобразует число 1 в число 19.) 2. Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала записывается исходная цепочка символов, после нее записывается исходная цепочка символов в обратном порядке, затем записывается буква, следующая в русском алфавите за той буквой, которая в исходной цепочке стояла на последнем месте. Получившаяся цепочка является результатом работы алгоритма. Например, если исходная цепочка символов была ЛЕС, то результатом работы алгоритма будет цепочка ЛЕССЕЛТ. Дана цепочка символов ЕН. Какая цепочка символов получится, если к данной цепочке применить алгоритм дважды (то есть к данной цепочке применить алгоритм, а затем к результату его работы еще раз применить алгоритм)? 3. От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе: – • – • – • • – – • – – При передаче радиограммы было потеряно разбиение на буквы, но известно, что в радиограмме использовались только следующие буквы: Т А У Ж Х – • – • • – • • • – • • • • Определите текст радиограммы (напишите). 4. В кодировке КОИ-8 каждый символ кодируется одним байтом. Определите информационный объем сообщения в битах из 30 символов в этой кодировке. 5. Определите значение переменной m после исполнения данного алгоритма k:=2 m:=k-2 k:=m * k +5 m:=m+2 7. Определите значение переменной z после выполнения следующего фрагмента программы x:=22 ; y:=12; y:=3*x-4*y; if x>y then z:=3*x+y else z:=2+x*y

У исполнителя Утроитель две команды , которым присвоены номера:

1.вычти один
2.умножь на три
Первая из них уменьшает число на экране на 1, вторая - утраивает его .
Запишите порядок команд в алгоритме получения числа 5 числа 26, содержащем не более 5 команд, указывая лишь номера команд (
Например, 21211 - это алгоритм :
умножь на три
вычти один
умножь на три
вычти один
вычти один
который преобразует число 2 в 13)
Если таких алгоритмов больше одного, то напишите любой из них

У исполнителя Утроитель две команды, которым присвоены номера: 1. умножь на 3, 2. вычти 2. Первая из них увеличивает число на экране в 3 раза, вторая

уменьшает его на 2. Запишите порядок команд в программе преобразования числа 3 в число 23, содержащей не более 4 команд, указывая лишь номера команд. (Например, 21211 -- это программа умножь на 3 прибавь 1 умножь на 3 прибавь 1 прибавь 1, которая преобразует число 1 в 14.) (Если таких программ более одной, то запишите любую из них Можно с объяснением



Вы находитесь на странице вопроса "у исполнителя делитель две команды которым присвоены номера:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.