Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить алгоритм, который находит сумму чисел: 3,7,11...N. Значение N вводится с клавиатуры.

5-9 класс

1245789630 22 июня 2013 г., 4:07:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ayka9971
22 июня 2013 г., 6:56:14 (10 лет назад)

1. Ввод числа n
2. Ввод чисел по очередности, и + тем самым наращиваешь счетчик т.е. 
ввел число 5 и его запоминаешь (sum:=sum+1).
3. Переменная sum выдаст тебе сумму введенных цифр.
Как же это будет выглядеть в программе
Begin
 Write('Введите число n: ');
 ReadLn(n);
For i:=1 to n do
 Begin
  Write('Вводишь число: ');
  ReadLn(a);
  sum:=sum+1; {наращиваешь счетчик}  
end;
end.

Ответить

Другие вопросы из категории

Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях ("включено" и "выключено"). Какое наименьшее количество лампочек

должно находиться на табло, что бы ч его помощью можно было передать 500 различных сигналов?
1)8 2)9 3)100 4)200

Читайте также

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль



Вы находитесь на странице вопроса "Составить алгоритм, который находит сумму чисел: 3,7,11...N. Значение N вводится с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.