Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найти среднее арифметическое цифр натурального числа n.( использовать частично стандартный алгоритм накопления суммы)

5-9 класс

Kozheva23 22 июня 2014 г., 9:16:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Uysynova04
22 июня 2014 г., 11:59:33 (9 лет назад)

var i,n,sum:integer;

begin

readln(n);

while n>0 do begin

i:=i+1;

sum:=sum+(n mod 10);

n:=n div 10;

end;

writeln(sum/i);

end.

Ответить

Другие вопросы из категории

Читайте также

Назовем натуральное число сверхнечетным, если оно состоит только из нечетных цифр. Требуется для заданного значения n найти n-е по счету сверхнечетное ч

исло. Вход: файл input.txt, содержащий только натуральное число n. Ограничения: 1 ≤ n ≤ 1000000. Выход: файл output.txt, содержащий одно натуральное число – n-е по счету сверхнечетное число. Пример: input.txt output.txt 13 35

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

исло M называется средним арифметическим двух чисел A и B, если M равно (A + B) / 2. Васе на день рождения подарили два числа A и B. Именинник легко

вычислил их среднее арифметическое и так обрадовался, что потерял число B. Помогите Васе восстановить потерянное число.

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);



Вы находитесь на странице вопроса "найти среднее арифметическое цифр натурального числа n.( использовать частично стандартный алгоритм накопления суммы)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.