Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом?Палиндромами называются числа, которые читаются одинаково

5-9 класс

слева-направо и справа-налево.
Напрмер, 8998, 3333.
Вводится целое число N (999 < N <10 000).
Вывести слово YES, если N является палиндромом и NO, если нет.

санr 10 авг. 2013 г., 21:47:33 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cyfral
10 авг. 2013 г., 22:28:07 (10 лет назад)

Предпоследняя строка. Перед ('NO'); должно быть write или writeln.


Var
  N, a, b, c, d: Integer;
begin
  Writeln('Vvedite chislo');
  ReadLn(N);
  a:=N mod 10;
  b:=N mod 100 div 10;
  c:=N mod 1000 div 100;
  d:=N div 1000;
  if (a=d) and (b=c) then write ('YES')
                     else writeln('NO');
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста! Определите источник и приемник информации, а также характер (односторонний, двухсторонний) передачи информации в следующих ситуациях:

1)школьник читает текст в учебнике; 2)бабушка читает письмо;3)мальчик просыпается от звонка будильника;4)разговаривают подруги Таня и Лена,

Читайте также

помогите пожалуйста решить задачу в паскале: Составить программу,проверяющую,является ли заданное натуральное число палиндромом,т.е.

таким,которое читается одинаково слева направо и справа налево(например:23132).

Введите с клавиатуры целое число в диапазоне 1-999.

а)Определите количество знаков в числе;
б)Определите четность числа;
в)Выведите описание числа,например,"нечетное однозначное число","четное двухзначное число" и тд.
Пример ввода: 347
Пример вывода: Нечетное трехзначное число

Введите с клавиатуры целое число в диапазоне 1-999.

а) определите количество знаков в числе;
б) определите чётность числа;
в) выведите описание числа ,наприме нечётное одназначное число чётное двухзначное число

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Дано трехзначное число. Проверить, является ли число палиндромом, т.е. числом, которое читается одинаково слева направо и справа налево (число единиц

может превосходить число сотен). Если не является, то вывести ближайшее следующее число-палиндром.



Вы находитесь на странице вопроса "Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом?Палиндромами называются числа, которые читаются одинаково", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.