Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите составить программу: Сформулировать массив из 12 произвольных чисел.Определить сумму квадратов элементов с чётными индексами. Результат вывести

10-11 класс

на экран.

Boguta1983 19 окт. 2014 г., 5:38:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vasilykolobov
19 окт. 2014 г., 6:17:22 (9 лет назад)

var a:array [1..100] of integer;
i,n,s:integer;

Begin
  randomize;
  n:=12;
  for i:= 1 to n do begin
    a[i]:=random(n*10)- 10*n div 2 ;
    write(a[i]:4);
    if i mod 10=0 then writeln;
  end;


  for i:= 1 to n do begin
    if i mod 2 =0 then

      s:=s+a[i];
  end;
  writeln(s);
 
End.

Ответить

Другие вопросы из категории

В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве.

Составить схему алгоритма и программу на языке программированияBasic для решения задачи по обработке одномерного массива.

привет всем)помогите пож-та с задачей. Найти и распечатать строку заданной целочисленной матрицы размером 10х10, в которой длина максимальной серии

минимальна. (Серия-последовательность одинаковых элементов. Длина серии-количество одинаковых элементов) .(паскаль) очень очень нужно))) заранее спасибо))

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел.составьте программу, с помощью которой напечатайте на одной строчке исходный

массив, а на следующей строке - сумму квадратов элементов с начетными индексами.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

Пожалуйста помогите составить программу.Заполнить массив из 500 элементов случайными числами в интервале [ 0 .. 100 ] . Отсортировать его по

возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» .



Вы находитесь на странице вопроса "помогите составить программу: Сформулировать массив из 12 произвольных чисел.Определить сумму квадратов элементов с чётными индексами. Результат вывести", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.