Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дан массив 5*6. Найти среднее арифметическое в каждой строке. Результаты положить в одномерный массив. паскаль

10-11 класс

Vasyamanyakov 31 мая 2014 г., 20:31:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asja30
31 мая 2014 г., 22:08:10 (9 лет назад)

program z;
var
s,i,j,n,m:integer;
a:array [1..100,1..100] of integer;
b:array [1..100] of real;
begin
n:=5; m:=6;
for i:=1 to n do
for j:=1 to m do
begin
writeln ('vvedi elementy');
readln (a[i,j]);
end;
for i:=1 to n do
begin
for j:=1 to m do
begin
write (a[i,j]:5);
end;
writeln;
end;
for i:=1 to n do
begin
s:=0;
for j:=1 to m do
begin
s:=s+a[i,j];
end;
b[i]:=s/m;
end;
for i:=1 to n do
writeln (b[i]:5:1);
readln;
end.

Ответить

Другие вопросы из категории

Последовательно вводя с клавиатуры рост учеников,

набрать команду из 7 человек, которые по росту будут больше или равны
задаваемому с клавиатуры контрольному росту R. Команду вывести на экран с пояснительным текстом.на паскале

Даны координаты трех точек на плоскости:

A(-12,57;-10,23),B(3,3;12,47),C(15,67;-10,32).Найдите с точностью до одного знака после запятой площадь треугольника АВС. В ответе укажите только число,отделяя дробную часть от целой запятой без пробелов,например,13,2

Читайте также

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.



Вы находитесь на странице вопроса "дан массив 5*6. Найти среднее арифметическое в каждой строке. Результаты положить в одномерный массив. паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.