Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ПОМОГИТЕ ОЧЕНЬ НАДО!

5-9 класс

Дано целое число n, которое больше либо равно 0 и меньше либо равно 9.
Написать программу, вычисляющую сумму всех двузначных чисел в записи которых нет n.

Natahakalinina93 06 июля 2014 г., 6:55:27 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
денчик12333
06 июля 2014 г., 9:02:19 (9 лет назад)

var n,i,one,dec,sum:integer;
begin
  writeln('Введите n'); readln(n);
  sum:=0;
  for i:=10 to 99 do begin
      one:= i mod 10; dec:=i div 10;
      if (one<>n)and(dec<>n) then sum:=sum+i;
  end;
  writeln(sum);
  readln
end.

Ответить

Другие вопросы из категории

Перечислите

меры предосторожности, которые следует соблюдать во избежание заражения вирусом

вычислить Y в зависимости от x,введенного с клавиатуры Y=( х2,если х>0

х+1,если х<=0
2 задача - вычислить Y в зависимости от x,введенного с клавиатуры (12,5*2,если -1<=х<0
х-1,если х<-1
12х,если х>0

Читайте также

РебяТ помогите очень надо, решит не могу не был на уроках, а она мне дала задачу.

Массив содержит 20 случайных чисел из промежутка [1..37] Выводит на экран эдементы больше 11, но меньше 22 ПОжалуйста помогите)



Вы находитесь на странице вопроса "ПОМОГИТЕ ОЧЕНЬ НАДО!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.