Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста решить в паскале: Дано трехзначное число.Определить являются ли цифры нечетными?

5-9 класс

Codex 11 апр. 2014 г., 15:34:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elvin12320
11 апр. 2014 г., 18:12:36 (10 лет назад)

Var a:integer; begin readln(a); if ((a mod 10) mod 2=0) and ((a div 100) mod 2=0) and(((a div 10) mod 10) mod 2=0) then writeln('четные') else writeln('нечетные') end.

+ 0 -
Malsonya99
11 апр. 2014 г., 21:08:57 (10 лет назад)

Лучше бы выбрал лучшим решением, на. Обоим пользы бы больше было.

Ответить

Другие вопросы из категории

Для чего человеку нужны линейка, транспортир, термометр, барометр, компас, телескоп, микроскоп , часы? Какие ещё приборы и приспособления вы знаете?

Запишите ответы, продолжив следующие фразы.а) Линейка нужна для б) Транспортир нужен для в) Термометр нужен для г) Барометр нужен для д) Компас нужен для е) Телескоп нужен для ж) Микроскоп нужен для з)Микроскоп нужен для и)Часы нужны для .

Укажите номера чисел по возрастанию:

Число Десятичный эквивалент Номер

Напишите программу, которая в последовательности натуральных чисел, оканчивается на 2.

Программа получает на выходе количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется числа, оканчивающиеся на 2
Количество чисел не превышает 1000. Введённые числа не превышают 30 000
Программа должна ввести одно числа - максимальное число, оканчивающиеся на 2

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "Помогите пожалуйста решить в паскале: Дано трехзначное число.Определить являются ли цифры нечетными?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.