Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В университете города N принято, что старшая цифра трехзначного номера студенческой группы обозначает номер факультета, средняя - последнюю цифру

10-11 класс

года поступления, младшая - порядковый номер группы. Программа по заданному номеру группы студента определяет, в каком году он поступил и на каком факультете учится. Номера факультетов следующие: 1 - исторический, 2 - экономический, 3 - юридический, 4 - математический, 5 - физический, 6 - химический, 7 - биологический, 8 - филологический, 9 - географический.

Lubamila 26 марта 2015 г., 3:10:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
митол
26 марта 2015 г., 4:46:44 (9 лет назад)

#include <iostream>
using namespace std;

int main()
{
    setlocale (LC_ALL,"Russian");
    int number;
    do
    {
        cout <<"Введите номер группы: ";
        cin >> number;
    }
    while (number<100 || number>999);
    char *groups[9]={"исторический","экономический","юридический",
                             "математический","физический","химический",
                             "биологический","географический","географический"};
    cout <<groups[number/100-1] <<", поступил в 200" <<number/10%10
           <<" году\n";
    return 0;
}
Как задание понял, так и написал

Ответить

Другие вопросы из категории

Из слова "форма" получить слово "фирма" 2) Дан текст "картографирования" получить слова ГРАФ, АРТ, РОФ. 3) Сколько раз в заданном условии повторяется буква

а.4) Дано предложение ( S) подсчитать количество символов (а).Помогите решить пожалуйста, очень срочно нужно. Прошу((((

Помогите!!!Срочно!!!

изначально растровое изображение имело палитру 65 536 цветов. В процессе его преобразования информационный объем уменьшился в 4 раза. Сколько цветов стало в палитре?

Решите информатику очень надо
Помогите пожалуйста решить побыстрее

Записать блок схему и программу для подсчёта кол-ва нечётных чисел в массиве А[1...20]
K изначально равно 0
К:=К+1 <------------------------------------------
а mod b - остаток от деления а на b. |
Если ... mod ... =1 то —--------------------

Читайте также

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух

последних цифр заданного числа; 3) число, образованное перестановкой второй и четвёртой цифр заданного числа.

Прошу вас помогите!Нужно написать программу,но только обязательно в Visual Basic!!!!!

На вход программе подаются сведения о
телефонах всех сотрудников некоторого учреждения. В первой строке
сообщается количество сотрудников N, каждая из следующих N строк имеет
следующий формат:

<Фамилия> <Инициалы> <телефон>

где <Фамилия> – строка, состоящая не более чем из 20 символов, <Инициалы> - строка, состоящая не более чем из 4-х символов (буква, точка, буква, точка), <телефон> – семизначный номер, 3-я и 4, я, а также 5-я и 6-я цифры которого разделены символом «–». <Фамилия> и <Инициалы>, а также <Инициалы <телефон> разделены одним пробелом. Пример входной строки:

Иванов П.С. 555-66-77

Сотрудники
одного подразделения имеют один и тот же номер телефона. Номера
телефонов в учреждении отличаются только двумя последними цифрами.
Требуется написать как можно более эффективную программу, которая будет
выводить на экран информацию, сколько в среднем сотрудников работает в
одном подразделении данного учреждения.


нужно как из четырёхзначного числа сравнить первую и последнюю цифру и две средних вопрос в том что как их вытащить из этого числа? первую и последнюю я

понял как
Console.WriteLine("Введите четырёхзначное число");
m = int.Parse(Console.ReadLine());
a = m / 1000; //последняя 1 цифра
b = m % 10;
допусти я ввёл число 6432 то прога выводит мне 6 и 2 мне надо ещё как то отдельно вывести цифры 4 и 3 и задать им отдельные переменные что бы сравнить



Вы находитесь на странице вопроса "В университете города N принято, что старшая цифра трехзначного номера студенческой группы обозначает номер факультета, средняя - последнюю цифру", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.