Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив из N целых элементов. Определить, есть ли в массиве положительные элементы.

5-9 класс

Lida111 11 февр. 2014 г., 2:18:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anyutanikitina1
11 февр. 2014 г., 3:01:39 (10 лет назад)

var
a:array[1..100]of integer;    
 i,n,k:integer;
begin     
read(n);
 for i:=1 to n do      
 begin                
a[i]:=random(100);                
write(a[i],' ');                
end;  
write;  
read(k);  
for i:=1 to n do  
if (a[i]>0)and (a[i] mod k=0) then
write(a[i],' ')                                
 else
write(''

Ответить

Другие вопросы из категории

Назовите имена объектов:

а)находящихся в вашем портфеле
б)расположенных на рабочем столе комп-а
в)используемых для хранения информации
г)изучаемых на уроках биологии,математики,географии,информатики

Задача на паскале:

Дано n чисел найти номер максимального числа.

помогите плиз!

Почему графический способ считается удобнее словесного? (если можно ответ в краткой форме)

составте слово из первых букв объектов на картинках.Полученное слово является ЧАСТОТА

а) характеристикой процессора
б) еденицей объема информации
в) еденицей измерения времени

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.



Вы находитесь на странице вопроса "Дан массив из N целых элементов. Определить, есть ли в массиве положительные элементы.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.