Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти

10-11 класс

НОД(

Nnura 11 дек. 2014 г., 15:23:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Semik93
11 дек. 2014 г., 16:19:50 (9 лет назад)

program nod1;
const InFile = 'Evclid.in';
OutFile = 'Evclid.out';
var m, n, k, nod, i, max: integer;
begin
 assign(input, infile);
 reset(InPut);
 Read(InPut, m); Read(InPut, n); Read(InPut, K);
 Close(inPut);
 nod:= 1;
if m >= n then
 max:= m
else max:= n;
if k > max then
 max:= k;
for i:= 1 to max do
 if (m mod i = 0) and (n mod i = 0) and (k mod i = 0) and (i > nod) then
 nod:= i;
assign(OutPut, OutFile);
ReWrite(OutPut);
Write(OutPut, nod);
Close(output);
end.

Ответить

Другие вопросы из категории

Pascal.

Даны массивы A(m) и Y(m), m≤16 . Найти сумму S : S=A1Ym+A2Ym-1+...+AmY1 . Если S<24 вывести ее на печать, в противном случае вывести на печать оба исходных массива.

Читайте также

1. По сторонам треугольника найти его периметр, площадь, высоты и радиус вписанного и описаного кругов.

2. Найти больше из трех данных чисел.
3. В одномерном массиве положительные элементы меншиты на 7.

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.



Вы находитесь на странице вопроса "Найти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.