Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны четыре натуральных числа. Просуммировать те из них, которые не содержат цифру 5

10-11 класс

Alalalalalala 20 нояб. 2016 г., 23:38:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Liliana001
21 нояб. 2016 г., 0:27:14 (7 лет назад)

х)

var

  i, k, b, a, sum: integer;

begin
  for i := 1 to 4 do
  begin
    readln(a);
    b := a;
    k := a;
    while (b > 0) do
    begin
      if (b mod 10 = 5) then
      begin
        k := 0;
      end;
      b := b div 10;
    end;
    sum := sum + k;
  end;
  writeln(sum);
end.

Ответить

Другие вопросы из категории

Какая информация называется субъективной?

Выберите один ответ:

Информация,
которая передаётся от одного субъекта другому

Информация
на дискете отдельного пользователя

Информация,
отражающая точку зрения отдельного пользователя

Информация
в бумажной форме

Информация,
не содержащая вирусов

Пожалуйста напишите полное решение задачи.

Если в некоторой системе счисления десятичное число 43 представлено в виде 47, то основание этой системы равно...

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Катя, Наташа, Римма и Лиля – студентки факультета иностранных языков – увлекаются музыкой и каждая из них играет на каком-нибудь инструменте, но только на

одном: гитаре, скрипке, арфе или фортепиано.

Каждая из них учится на одном из отделений факультета: английского, французского, немецкого или испанского языка.

Та из них, которая играет на гитаре, учится на отделении испанского языка. Наташа не играет ни на скрипке, ни на арфе, и не учится на отделении английского языка. Катя тоже не играет ни на арфе, ни на скрипке и не учится на отделении английского языка. Студентка отделения немецкого языка не играет на арфе. А Римма учится на отделении французского языка и не играет на скрипке.

На каком инструменте играет и на каком отделении факультета иностранных языков учится каждая из студенток?

получается лилия играет на скрипке и не играется на гитаре, не учится на французском.

рима на французском но не играет на скрипке

наташа не на англйским и не играет не на скрипке не на арфе

катя не на английском не на скрипке не на арфе



Вы находитесь на странице вопроса "Даны четыре натуральных числа. Просуммировать те из них, которые не содержат цифру 5", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.