Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль АВС! Составить программу,определяющую какая буква слова x(первая или последняя) чаще встречается в слове y.

5-9 класс

Martinashtosel2 08 окт. 2013 г., 12:37:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Klitvinova
08 окт. 2013 г., 15:29:14 (10 лет назад)

VAR
   s: String;
   k1,k2,i: LongInt;
BEGIN
   Read(s);
   
   k1 := 0; k2 := 0;
   for i := 1 to Length(s) do begin
      if (s[i] = s[1]) then Inc(k1);
      if (s[i] = s[Length(s)]) then Inc(k2);
   end;
   
   if (k1 > k2) then Write('Первая буква встречается чаще последней буквы.');
    if (k1 < k2) then Write('Последняя буква встречается чаще первой буквы.'); 
   if (k1 = k2) then Write('Первая и последняя буквы встречаются одинаковое кол-во раз.'); 
END.

Ответить

Другие вопросы из категории

Язык программирования С++.

1. Даны четыре действительных числа a, b, c, x. Выяснить, пройдёт ли кирпич со сторонами a, b, c, в круглое отверстие радиуса x?
2. Дано трёхзначное натуральное число. Найти сумму цифр этого числа.
3. В данном двузначном натуральном числе подсчитать, сколько цифр больших 6, но меньших 9.
4. Даны три действительных числа больших нуля. Выяснить, являются ли они сторонами прямоугольного треугольника?

Читайте также

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

С ПОМОЩЬЮ ПАСКАЛЯ

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня.
Составить программу, определяющую, какой суммарный путь пробежал спортсмен за 7 дней.

мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(

N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) максимального среди отрицательных элементов и его номера. заранее огромное спасибо! очень нужно!



Вы находитесь на странице вопроса "Паскаль АВС! Составить программу,определяющую какая буква слова x(первая или последняя) чаще встречается в слове y.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.