Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить программу,определяющую какая буква слова x(первая или последняя) чаще встречается в слове y. Паскаль!!!

5-9 класс

кисса96 16 апр. 2015 г., 2:04:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mamaangelika
16 апр. 2015 г., 2:59:21 (9 лет назад)

var x,temp:string;
     first,last:char;
     k1,k2:integer;
begin
   write ('X = ');
   readln (x);
   k1:=0;
   k2:=0;
   first:=x[1];
   last:=x[length(x)];
   temp:=x;
   while (pos(first,temp)>0) do
    begin
      inc(k1);
      delete (temp,pos(first,temp),1);
    end;
   temp:=x;
   while (pos(last,temp)>0) do
    begin
      inc(k2);
      delete (temp,pos(last,temp),1);
    end;
   if (k1>k2) then writeln ('First') else
    if (k2>k1) then writeln ('Last') else
      writeln ('Equal');
end.

+ 0 -
Dashaf98
16 апр. 2015 г., 4:52:29 (9 лет назад)

Комментарий удален

+ 0 -
VeeN
16 апр. 2015 г., 7:49:16 (9 лет назад)

Комментарий удален

+ 0 -
Denmen2004
16 апр. 2015 г., 8:40:09 (9 лет назад)

Я не знаю,что такое прога)))

+ 0 -
Anika2002
16 апр. 2015 г., 10:47:00 (9 лет назад)

Комментарий удален

+ 0 -
Kopatela
16 апр. 2015 г., 11:34:07 (9 лет назад)

Неа, что то она не по условию

Ответить

Другие вопросы из категории

Решите пожалуйста.Сделаю лучшим ответом))

Дана последовательность целых чисел,заканчивающаяся нулем.Написать программу,которая выводит последнее ненулевое число последовательности.

Читайте также

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

С ПОМОЩЬЮ ПАСКАЛЯ

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня.
Составить программу, определяющую, какой суммарный путь пробежал спортсмен за 7 дней.

1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите

программу определяющую каких элементов в точке больше положительных или отрицательных

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль



Вы находитесь на странице вопроса "Составить программу,определяющую какая буква слова x(первая или последняя) чаще встречается в слове y. Паскаль!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.