Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задайте массив из 10 элементов с помощью датчика случайных чисел . Найдите разность наибольшего элемента и среднего арифметического элементов этого

10-11 класс

массива. Выведите на экран исходный массив и полученную разность .

Bulgunmuchaeva1 01 сент. 2016 г., 14:31:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Софья200
01 сент. 2016 г., 17:04:36 (7 лет назад)

Program pr;
uses crt;
Var a:array[1..10] of integer;
    i,max:integer;
    s:real;
Begin
for i:=1 to 10 do Begin a[i]:=random(100); Write(a[i],';'); end;
Writeln;
 max:=abs(a[1]-a[2]);
for i:=1 to 9 do
    if abs(a[i]-a[i+1])>max then max:=abs(a[i]-a[i+1]);
    s:=0;
for i:=1 to 10 do s:=s+a[i];

s:=s/10;
Writeln('max=',max);
Writeln('среднее арифметическое=',s);
readln;
end.

Ответить

Другие вопросы из категории

очень надо, помогите прошу Дано целое число К. Вывести строку-описание оценки, соответствующей числу К (1- "плохо" , 2-

"неудовлетворительно" , 3 - "удовлетворительно" , 4- "хорошо" , 5- "отлично". Если К не лежит в диапазоне 1-5 , вывести "ошибка".

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

Помогите, пожалуйста. Паскаль ABC. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите произведение элементов, имеющих

нечетные индексы. Выведите на экран исходный массив и полученное произведение.

Помогите пожалуйста!!!! Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все элементы с нечетными индексами

на минимальный. Выведите на экран исходный и полученный массивы.



Вы находитесь на странице вопроса "Задайте массив из 10 элементов с помощью датчика случайных чисел . Найдите разность наибольшего элемента и среднего арифметического элементов этого", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.