Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

10-11 класс

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

ЯНОЧКАbabayan 27 июля 2014 г., 11:43:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КОЗЮЛЯ1255
27 июля 2014 г., 13:26:27 (9 лет назад)

1. var a,s:integer;
begin
writeln ('введи 3-значное число');
readln (a);
if (a>99) and (a<1000) then begin
while a>0 do
begin
s:=s+sqr(a mod 10);
a:=a div 10;
end;
writeln (s);
end else writeln ('Ошибка ввода');
end.

2. var a,s,k:longint;
begin
writeln ('введи 8-значное число');
readln (a);
if (a>9999999) and (a<100000000) then begin
while a>0 do
begin
k:= a mod 10;
s:=s-k*k*k;
a:=a div 10;
end;
writeln (s);
end else writeln ('Ошибка ввода');
end.

Ответить

Другие вопросы из категории

Паскаль. Циклической структурой.

Дано целое число N (> 1). Вывести наибольшее целое К, при котором выполняется неравенство 3^K < N, и само значение 3^K
^ - степень.

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.

Читайте также

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ

Помогите пожалуйсто! 1). Составить алгоритм и программу определения расстояния между точкамиМ( х, у) и М1( х1, у1). 2)составить алгоритм и программу для

заданного трехзначного числа вычислить среднее арифметическое и среднее геометрическое цифр , образующих это число .



Вы находитесь на странице вопроса "1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.