Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите составить программу(с обьяснением).Паскаль.Массивы.ЗАДАЧА: Определить минимальный элемент и его индекс(номер) в нечетных элементах одномерного

10-11 класс

массива произвольной длины.

Breakfas 22 дек. 2016 г., 6:42:46 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ольгамоисеенко
22 дек. 2016 г., 8:27:38 (7 лет назад)

program z1;
uses crt;
var n,i,min,k:integer;
a: array[1..100] of integer;

begin
randomize;
writeln('Ââåäèòå êîë-âî ýëåìåíòîâ â ìàññèâå');
readln(n);
for i:=1 to n do
begin
a[i]:=random(100);
write(a[i]:4);
end;
writeln;
min:=a[1];
for i:=1 to n do
begin
if i mod 2 <> 0 then
begin
if a[i]<min then min:=a[i];
k:=i;
end;
end;
writeln('Ýëåìåíò ',min, ' èíäåêñ ',i);
end.

Ответить

Другие вопросы из категории

решите плиз !

Ученик
набирает доклад по литературе на компьютере, используя кодировку КОИ-8.
Определите, какой объем памяти займет фраза:

Я вас
любил безмолвно, безнадежно, то робостью, то ревностью томим.

Одномерные массивы паскаль

Заменить все элементы массива, большие второго и меньшие пятого, на сумму второго и пятого.

Помогите пожайлуста!!!Мне очень надо!!!

Вычислите F3(в 16 с.и)-E9(в 16 с.и)

При регистрации в интернет-магазине пользователю автоматически создается пароль, состоящий только из цифр от0 до 9. Пароль состоит из 8 символов и

кодируется одинаковым, минимально возможным количеством бит. Сколько байт памяти потребуется, чтобы сохранить информаци о пароле 180 пользователей?

Читайте также

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10) количества положительных элементов.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!!!!

Составить программу на Паскале. Ввести 10 целых случайных чисел (в интервале от -10 до 10). Вывести исходный массив. Найти и вывести: 1) минимальный элемент и его индекс; 2) сумму всех элементов массива; 3) количество отрицательных элементов. К каждому элементу массива прибавить 1, вывести получившийся массив. Подсказка: 1)random(10)-10 2) положительные: >0 неположительные: <=0 отрицательные: <0 неотрицательные:>=0

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

Помогите, пожалуйста, написать программы на языке паскаль:

1,Найти
наименьший элемент массива (начиная с k-го) и
его порядковый номер. Поменять местами k-тый и найденный минимальный элемент.



Вы находитесь на странице вопроса "Помогите составить программу(с обьяснением).Паскаль.Массивы.ЗАДАЧА: Определить минимальный элемент и его индекс(номер) в нечетных элементах одномерного", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.