Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Ввести массив F(n) вещественных

10-11 класс

чисел. Если последний элемент массива положительный, то найти max среди
элементов массива и заменить его значений последний элемент массива. Массив
распечатать. Иначе – дать сообщение «Массив остался без изменений»

олошка 06 окт. 2013 г., 3:04:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gnork150503
06 окт. 2013 г., 5:59:45 (10 лет назад)

Program Zadacha;
Const n = 5;
Var a: Array[1..n] Of Real;
i, j: Integer;
Begin
WriteLn('Введите ', n, ' чисел через пробел');
For i := 1 To n DoRead(a[i]);
If a[n] >= 0 ThenBeginj := 1;
For i := 1 To n Do
If a[i] > a[j] Then
j := i;a[n] := a[j];
For i := 1 To n Do
Write(a[i], ' ');
End
Else
WriteLn('Массив остался без изменений');
ReadLn;
End.

+ 0 -
Petrovna131
06 окт. 2013 г., 8:03:16 (10 лет назад)

Сейчас нету времени решать,но если не срочно то завтра решу)

Ответить

Другие вопросы из категории

Доступ к файлу come.doc, находящемуся на сервере doc.net, осуществляется по протоколу ftp. Фрагменты

адреса файла закодированы буквами от А до Ж. Запишите последовательность этих букв, кодирующую адрус указанного файла в сети Интернет:
А) ://
Б) come
В) /
Г) .doc
Д) ftp
Е) net
Ж) doc.

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

ВпрограммеC++.Ввести массив символов разделителей с

заданным количеством символов,число
и массив строк текста,содержащий
неизвестное заранее количество строк.Последней строкой текста будет строка,после ввода которой количество одинаковых
слов в тексте превысит заданное в
исходных данных число.Из строк введенного
текста сформировать другой текст,в
котором строки будут располагаться в
порядке увеличения количества символов
разделителей с одновременным удалением
строк,в которых было повторение любого
символа разделителя.

помогите пацантре !!! делать в Excel VBA

1) Ввести массив данных A(n);A(5)
2) Найти сумму нечётных элементов массива . (S)
3) Все чётные элементы массива разделить на S
4) Ввести преобразованный массив



Вы находитесь на странице вопроса "Ввести массив F(n) вещественных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.