Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ребят, выручайте!!! Задание по Pascal. 1. В массиве А[N] занесены натуральные числа. Найти сумму тех элементов, которые кратны данному К. 2. В

10-11 класс

целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов.

Karinasoshnikov 19 июля 2013 г., 11:06:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gjhljy6767
19 июля 2013 г., 12:03:05 (10 лет назад)

1.
var
  k, sum, n, i: integer;
  A: array of integer;
begin
  writeln('Введите размерность массива: ');
  readln(n);
  SetLength(A, n);
  writeln('Введите K: ');
  readln(k);
  writeln('Введите ', n, ' элементов массива :');
  for i := 0 to n - 1 do
  begin
    readln(A[i]);
    if A[i] mod k = 0 then sum := sum + A[i];
  end;
  writeln('Результат: ', sum);
end.

Ответить

Читайте также

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Задачи pascal.(34б)

Если все элементы одномерного массива положительные то вывести сообщение "УСЛОВИЕ ВЫПОЛНЯЕТСЯ" иначе "УСЛОВИЕ НЕ ВЫПОЛНЯЕТСЯ"
Дан массив из N ЭЛЕМЕНТОВ. Определить произведение элементов кратных заданному k(k-задается с клавиатуры).
Дан массив из N элементов.Определить ПРОИЗВЕДЕНИЕ тех элементов,которые кратные 3.

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

На бейсике Даны массивы A(m) и B(m), m<=12 Сформулировать массив С по правилу: C1=Bm+A1 C2=Bm-1+A2

------------

Cm=B1+Am

Найти сумму S элементов массива С. Вывести на печать массивы A,B,C и полученную сумму S..



Вы находитесь на странице вопроса "Ребят, выручайте!!! Задание по Pascal. 1. В массиве А[N] занесены натуральные числа. Найти сумму тех элементов, которые кратны данному К. 2. В", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.