Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать в паскаль. Вводится две строки. Написать пользовательскую функцию которая возвращает строку 'da' если количество символов в этих строках

10-11 класс

одинаково и возвращает 'net' если неодинаково.

Светка4325 01 нояб. 2014 г., 11:15:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zinov2015
01 нояб. 2014 г., 12:24:41 (9 лет назад)

function p(s1,s2:string):string;
begin
if length(s1)=length(s2) then p:='da' else
p:='net'
end;

Это функция. Если вся программа заключается лишь в нахождении da или net, тогда будет так:

var s1,s2:string;
function p(s1,s2:string):string;
begin
if length(s1)=length(s2) then p:='da' else p:='net'
end;
begin
readln(s1);
readln(s2);
s1:=p(s1,s2);
write(s1);
end.

Ответить

Другие вопросы из категории

Не могу решить задачу, помогите.
1) В ячейке B1 записана формула =2*$A1. Какой вид приобретет формула, после того как ячейку B1 скопируют в ячейку B3 B C2 2)СРАВНИТЕ РАЗЕРЫ ПАМЯТИ

НЕОБХОДИМЫЕ ДЛЯ ХРАНЕНИЯ ИЗОБРАЖЕНИЙ ПЕРВОЕ ИЗОБРАЖЕНИЕ 4-ЦВЕТНОЕ ЕГО РАЗМЕР 64Х128ПИКСЕЛЕЙ ВТОРОЕ ИЗОБРАЖЕНИЕ 16 ЦВЕТНОЕ ЕГО РАЗМЕР 32Х32 ПИКСЕЛЕЙ 3)ПРОПУСКАЯ СПОСОБНОСТЬ НЕКОТОРОГО КАНАЛА СВЯЗИРАВНА128000 БИТ/СЕК СКОЛЬКО ВРЕМЕНИ ЗАЙМЕТ ПЕРЕДАЧА ПО ЭТОМУ КАНАЛУ ФАЙЛА ОБЪЕМОМ 1.5 МБАЙТ 4)ПЕРЕВЕДИТЕ В ДЕСЯТИЧНУЮ СИСТЕМУ СЧИСЛЕНИЯ ЧИСЛА 111012 И 1000111112

Читайте также

Написать в Паскаль программу для решения следующей задачи.

Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку , добавляя после каждого символа символ '0'.

Помогите в с++ билдер. В строке, состоящей из групп нулей и единиц, подсчитать количество символов в самой длинной группе.(напишите код в консоли)...

вот пример который считает количество едениц в строках с нечётным количеством символов
//---------------------------------------------------------------------------

#include
#include
#include
#include
#pragma hdrstop

//---------------------------------------------------------------------------

#pragma argsused
int main(int argc, char* argv[])
{
int n,s, i, nst,p,k, len,t=0;
char a[81];
puts(" Input string ");
gets(a);
len = strlen(a);
s=0;
n=0;
a[len+1]='\0';
a[len]=' ';
for(i=0; i<=len; i++)
{
if(a[i]!=' ')
{
n++;
if(a[i]=='1')
t++;
}
else
{
if(n%2!=0)s+=t;
n=0;
t=0;
}
}
printf("\nkoli4ectvo 1= %d", s);
puts("\nPress any key to close ... ");
getch();
return 0;
}
//---------------------------------------------------------------------------

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

Составьте программу, которая заменяет все буквы "о" на символ "*" в строке s.

Использовать можно функции pos, length, copy, delete, insert.



Вы находитесь на странице вопроса "Написать в паскаль. Вводится две строки. Написать пользовательскую функцию которая возвращает строку 'da' если количество символов в этих строках", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.