Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите пожалуйста решить в паскале. Создайте двухмерный массив Х, имеющий четыре строки и три столбца, и найдите в нем максимальный по абсолютному

10-11 класс

значению элемент, а также номера строки и столбца, содержащих этот элемент. Например, в массиве, показанном справа, максимальный по абсолютному значению элемент равен 8, он находится во 2-й строке 3-го столбца.

Olga20082 14 янв. 2014 г., 15:11:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kuabi
14 янв. 2014 г., 16:36:08 (10 лет назад)

Program vadim_Loh;
uses crt;
const
N = 10;
var m,o,max,i,j:integer;
A:array [1..4,1..3] of integer;
begin
max:=0;
randomize;
for i:=1 to 4 do
begin
for j:=1 to 3 do
begin
A[i,j]:=random(100);
end;
end;
for i:=1 to 4 do
begin
for j:=1 to 3 do
begin
write(a[i,j]:5);
end;
writeln;
end;
for i:=1 to 4 do
for j:=1 to 3 do
if A[i,j] > max then
begin
max:=A[i,j];
o:=i;
m:=j;
end;
writeln('CTOLBI= ',m,' ','STROKI= ',o,' MAX= ',max);
end.

+ 0 -
Pishpishtutu
14 янв. 2014 г., 17:31:59 (10 лет назад)

вот матрица

+ 0 -
Tatyana199723
14 янв. 2014 г., 20:27:37 (10 лет назад)

ща сделаем

Ответить

Другие вопросы из категории

У исполнителя «Арифмометр» две команды, которым присвоены номера:

1) прибавь 3,
2) раздели на 2
Первая прибавляет к числу на экране 3, вторая делит число на экране на 2. Алгоритм работает только с натуральными числами. Составьте алгоритм получения из числа 23 число 4, содержащий наименьшее количество команд. Ответ будет состоять только из номеров команд

Решите что сможете пожалуйста

Читайте также

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.



Вы находитесь на странице вопроса "помогите пожалуйста решить в паскале. Создайте двухмерный массив Х, имеющий четыре строки и три столбца, и найдите в нем максимальный по абсолютному", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.