Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дана целочисленная квадратная матрица. Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

10-11 класс

Нужна на языке си.

TiMaBRO2013 15 апр. 2014 г., 20:13:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Figurinaolga
15 апр. 2014 г., 22:36:31 (10 лет назад)

#include <stdio.h>
#define n 5
int main(void){
        int a[n][n];
        int i,j;
        int sd=0,s=0,k=0;
        for(i=0;i<n;i++){
            for(j=0;j<n;j++){
                scanf("%d", &a[i][j]);
            }
        }
        for(i=0;i<n;i++) sd+=a[i][i];
        for(i=0;i<n;i++){
            for(j=0;j<n;j++){
                s+=a[i][j];
            }
            if (s==sd) k++;
            s=0;
        }
        printf("%d",k);
return 0;
}

Ответить

Читайте также

Работа с двумерными массивами.

Помогите написать программу, которая чётные элементы последовательности уменьшает в 2 раза, а нечётные увеличивает в 2 раза.
И ещё одна программа, которая находит сумму элементов, которые находятся под главной диагональю.
Заранее спасибо.

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!!

1.Дано массив 5*5, заполнить массив случайными числами не больше 30 и найти сумму парных элементов массива, которые находятся под главной диагонали и количество не парных элементов которые находятся над главной диагонали.

Составьте программу, которая для одномерного массива, содержащего n элементов вычисляет и отображает: 1) сумму элементов массива; 2)произведение чётных

элементов; 3) сумму элементов которые делятся на 3; 4) минимальный и максимальный элемент. (используя procedure или function, но чтоб была рекурсия)ПОЖАЛУЙСТА ПОМОГИТЕ ВОПРОС ЖИЗНИ И СМЕРТИ!!



Вы находитесь на странице вопроса "Дана целочисленная квадратная матрица. Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.