Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Решите ну ктонибуть уже устал ждать

10-11 класс

Написать програму на языке паскаля с использование цикла с пердусловием для решении следущей задачи:

дано натуральное как минимум трёхзначное число.Определить,верно ли ,что удвоеная сумма друх его послеследних цифр меньше квадрата первой цифры.

Orudzhev94 13 июля 2014 г., 21:12:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Штука
13 июля 2014 г., 22:22:46 (9 лет назад)

Проверено в турбопаскаль 7

var ost,n:longint;
i,kvadrat, udvsumma:integer;
numbers:array[1..10] of integer;
begin
writeln('-------------------------------------');
write('input n:');
readln(n);
writeln('vi vveli:',n);
ost:=n;
i:=0;
while (ost>0) do
begin
i:=i+1;
numbers[i]:=ost mod 10;
ost:=ost div 10;

end;
if(i<3) then
begin
writeln('Obman!!! Nado vvesti minimum 3 znaka chislo');
end
else
begin
kvadrat:=numbers[i]*numbers[i];
udvsumma:=2*(numbers[1]+numbers[2]);
writeln('kvadrat pervogo=', kvadrat);
writeln('udvoennaya summa poslednih=', udvsumma);
if(udvsumma<kvadrat) then
writeln('Vse verno, udvoennaya summa menshe')
else
writeln('ne verno, udvoennaya summa ne menshe');

end;
writeln('press enter');
readln;
end.

Ответить

Другие вопросы из категории

Сколько байт в 32 Гбайт
матрицу10 на 10 заполнить случайными однозначными числами вывести на экран.

Наити:1.количество четных чисел элементов матрицы
2.количество нечетных чисел элементов матрицы
3.сумму чисел диагонали матрицы
4.максимальный элемент матрицы и его адрес.
Написать блок схему и программу

Читайте также

Люди,прошу вас, помогите пожалуйста, я уже долго сижу над этой задачей,не могу решить,пожалуйста помогите! =(((

найти номер третьего положительного элемента в потоке из 10 чисел или сообщить,что трех положительных элементов нет. (Решать без массива)

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

ХОТЯ БЫ ОБЪЯСНИТЕ КАК РЕШИТЬ! ОЧЕНЬ НАДО! НУ ВСЕ ПУНКТЫ ЧТО ЕСТЬ ОТДАЮЮЮЮЮ Тело брошено

вертикально вверх со скоростью 40 км/ч. Найти значение проекции скорости этого тела в течении 6 секунд, через каждые 0,5 секунд


Надо решить в электронной таблице HELP PLEASE!



Вы находитесь на странице вопроса "Решите ну ктонибуть уже устал ждать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.