Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите пожалуйста нужна программа на паскале с циклом параметра(for)

10-11 класс

Шеги 13 нояб. 2013 г., 18:40:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelina2003078178
13 нояб. 2013 г., 19:50:02 (10 лет назад)

program z;
var n,s,s1,i:integer;
begin s:=1; s1:=1; s1:=1;
write('n='); read(n);
for i:=1 to n do
begin
if i mod 2 =0 then s:=i*s;
if i mod 2 <> 0 then s1:=i*s1;
end;
write('произведение четных = ',s, ' произведение нечетных = ',s1);
end.

+ 0 -
Well57rus
13 нояб. 2013 г., 21:05:16 (10 лет назад)

var n,f,i:integer;
begin
  readln (n);
  f:=1;
  for i:=1 to n do
    if ((n mod 2 = 1) and (i mod 2 = 1)) or 
       ((n mod 2 = 0) and (i mod 2 = 0)) then f:=f*i;
  writeln (f);
end.

Ответить

Другие вопросы из категории

Помогите расписать программу по строчкам (за что каждая строка отвечает)

#include <iostream>
#include <cstdlib>
using namespace std;
int main() {

int n;
float sum=0;
cout<<"Vvedite n: ";

cin>>n;

float a[n+1], b[n+1];

for (int i=1; i<=n; i++){
system("cls");
cout<<"Vvedite "<<i<<"-e chislo massiva a: ";
cin>>a[i];

sum+=a[i];

b[i]= sum/i;
}

system("cls");

cout<<"B = [";
for (int i=1; i<n; i++){
cout<<b[i]<<", ";
}

cout<<b[n]<<"] ";

system("pause");
return 0;
}

1.

Читайте также

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.



Вы находитесь на странице вопроса "помогите пожалуйста нужна программа на паскале с циклом параметра(for)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.