Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

решите задачу пожалуйста по информатике в форме паскаль!!!

5-9 класс

Дана последовательность 1,3,5,7,.....
Вывести первый член последовательности больше некоторого В.

ЛераСар 23 февр. 2015 г., 12:03:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastya087
23 февр. 2015 г., 14:29:37 (9 лет назад)

var
b: integer;
begin
readln(b);
if (b mod 2)=0 then write(b+1) else write(b+2);
end.

В условии просто последовательность нечётных чисел. Если b чётное, то ближайшее большее будет больше его на 1. Если b нечётное, то ближайшее большее нечётное будет b+2

+ 0 -
Natasha9909
23 февр. 2015 г., 17:24:48 (9 лет назад)

Принялся.

+ 0 -
Marishcaa
23 февр. 2015 г., 19:12:59 (9 лет назад)

спасибо большое)

+ 0 -
Bizvik
23 февр. 2015 г., 20:48:42 (9 лет назад)

Под последовательностью имеется ввиду массив?

Ответить

Другие вопросы из категории

Что получится в результате работы

следующего алгоритма, если 1)

Помогите пожалуйста №7
помогите пожалуйста срочно!!

Читайте также

Вася, Илья, Коля, Никита и Петя решали задачи по информатике. Всего было 5 задач. Кто сколько задач решил, если известно, что: Вася и Коля решали все

задачи вместе; Петя решил на 2 задачи больше, чем Вася; Илья решил меньше задач, чем Коля; Никита решил больше задач, чем Илья, но меньше, чем Вася; каждый решил хотя бы по одной задаче.

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)

Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки,

затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))

Решите задачу

Решите задачу с помощью рассуждения (рассуждения присылать тоже)
Задача: В одном доме живут 3 товарища: Вася, Боря и Дима.
Один из них играет в футбол, другой пишет стихи, а третий лучше всех играет в шахматы.
Известно : 1-ВАсин друг с огорчением сказал "Вчера я не сумел реализировать пинальти" 2-товарищ поэта сказал" Дима! Написал бы и ты что нибудь и для нашей футбольной команды"
Назовите имена футболиста, шахматиста, поэта (с рассуждением)

Помогите срочно! По информатике задали 7 вопрос: Возле школы растут шесть деревьев: сосна, берёза, липа, тополь, ель и клён. Какое из этих деревьев самое

низкое, если известно, что берёза ниже тополя, липа выше клёна, сосна ниже ели, липа ниже берёзы, сосна выше тополя?
И второй вопрос: Пятеро одноклассников - Аня, Саша, Лена, Вася и Миша - стали победителями школьных олимпиад по истории, математике, информатике, литературе и географии. Известно, что: 1) победитель олимпиады по информатике учит Аню и Сашу работе на компьютере; 2) Лена и Вася заинтересовались информатикой; 3) Саша всегда побаивался истории; 4) Лена, Саша и победитель олимпиады по литературе занимаются плаванием; 5) Саша и Лена поздравили победителя олимпиады по математике; 6) Аня сожалеет о том. что у неё остаётся мало времени на литературу.
Победителем какой олимпиады стал каждый из этих ребят?



Вы находитесь на странице вопроса "решите задачу пожалуйста по информатике в форме паскаль!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.