Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

тема: одномерные массивы, написать программу использую rite, riteln

10-11 класс

задача; Все элементы кратные трем делятся на три, остальные умножаются на 3.

Nastya186767 07 апр. 2017 г., 11:19:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rom4ik1997
07 апр. 2017 г., 12:56:08 (7 лет назад)

const N=...;//указываешь количество элементов массива
var a:array [1..N] of integer;
i:integer;
begin
for i:=1 to N do 
readln(a[i]);
for i:=1 to N do begin
 if a[i] mod 3 =0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;
writeln(a[i]);
end;
end.

Ответить

Другие вопросы из категории

Pascal.Срочно, выручайте)

Прямоугольный участок имеет размеры А на В. Сколько нужно столбов для ограждения участка, если их ставят через 2 метра.

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

1. написать программу, производящее "неформатный" вывод разных значений

2. написать программу, производящее "форматный" вывод разных значений
3. написать программу использующие процедуру writeln c параметрами и без параметров

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!



Вы находитесь на странице вопроса "тема: одномерные массивы, написать программу использую rite, riteln", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.