Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Сделать 4, 7 задание... Чтобы выполнить задание нужно написать программу Pashal ABC

10-11 класс

Полинка2 13 июня 2014 г., 7:30:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ропри
13 июня 2014 г., 9:37:01 (9 лет назад)

var a: array [1..100] of integer; i, temp: integer;
begin
     randomize;
     writeln();
     for i := 1 to 100 do
         a[i] := random(1000);
     for i := 1 to 100 do
         write(a[i], ' ');
     writeln();
     temp := a[1];
     for i := 2 to 100 do
         a[i - 1] := a[i];
     a[100] := temp;
     for i := 1 to 100 do
         write(a[i], ' ');
end.
--------------
var x, y: array [1..1000] of real; i, n: integer; left, right, up, down: real;
begin
     read(n);
     for i := 1 to n do
         read(x[i], y[i]); {Вершины вводятся с клавиатуры}
     left := x[1];
     right := x[1];
     up := y[1];
     down := y[1];
     for i := 2 to n do
     begin
          if(left > x[i])
          then
              left := x[i];
          if(right < x[i])
          then
              right := x[i];
          if(down > y[i])
          then
              down := y[i];
          if(up < y[i])
          then
              up := y[i];
     end;
     writeln('left-down vertex: (', left, ', ', down,')');
     writeln('right-up vertex: (', right, ', ', up,')');
     writeln('perimeter: ', 2 * (right - left + up - down));
     writeln('area: ', (right - left) * (up - down));
end.

Ответить

Другие вопросы из категории

Помогите пж очень нужно

Выполнить вычитание
a) 1101110010,01(2) - 111110110,01(2)
б) 1653,1(8) - 415,6(8)
в) 1В9,4(16) - 1В4,6(16)

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы Е, Г, Э, 2, 0, 1, 3.

Каждый такой пароль в компьютерной программе записывается минимально возможным и одинаковым целым количеством байт (при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит). Определите объём памяти, отводимый этой программой для записи 25 паролей.
1) 150 байт 2) 175 байт 3) 200 байт 4) 225 байт

Читайте также

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Нужно написать программу... Задание: Адрес, запрашиваемый пользователем, обычно состоит из четырех частей, из которых первые три

являются доменными именами различного уровня и разделены точками, а последняя отделена от них двоеточием и является портом, к которому обращается пользователь. Например, при обращении пользователя к www.ifmo.ru:8080 слово ru является доменным именем первого уровня, слово ifmo — доменным именем второго уровня, слово www — доменным именем третьего уровня, а 8080 является портом.

Вам необходимо по списку запросов пользователей в таком формате перечислить все различные порты, к которым обращались пользователи.

Формат входного файла

В первой строке входного файла input.txt находится одно натуральное число n (1 ≤ n ≤ 100) — количество адресов в данном вам списке. В следующих n строках содержатся сами адреса в формате, описанном выше.

Все доменные имена всех уровней состоят только из строчных букв латинского алфавита, а порты — только из цифр. Длина любого данного вам адреса не превышает 250 символов.

Формат выходного файла

В первой строке выходного файла output.txt выведите одно целое число k — количество различных портов, к которым обращались пользователи. В следующих k строках выведите сами порты. Каждый порт должен быть выведен ровно один раз в отдельной строке. Порты могут быть выведены в любом порядке.

Пример входных и выходных данных

input.txt


3
www.ifmo.pl:3389
www.ya.pl:65535
www.ifmo.kz:3389

output.txt

2
65535
3389



Вы находитесь на странице вопроса "Сделать 4, 7 задание... Чтобы выполнить задание нужно написать программу Pashal ABC", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.