Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Введите с клавиатуры четыре числа. Найдите и выведите н экран сумму и произведение тех чисел, значения которых отрицательны.

5-9 класс

Ainagul05 29 окт. 2014 г., 2:04:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mabina24012004
29 окт. 2014 г., 3:40:51 (9 лет назад)

var a,b,c,d,a1,b1,c1,d1:real;
begin
a1:=0;b1:=0;c1:=0;d1:=0;
read (a,b,c,d);
if (a<0) or (b<0) or (c<0) or (d<0) then
begin
if (a<0) then a1:=a;
if (b<0) then b1:=b;
if (c<0) then c1:=c;
if (d<0) then d1:=d;
writeln ('Сумма отрицательных = ',a1+b1+c1+d1);
a1:=1;b1:=1;c1:=1;d1:=1;
if (a<0) then a1:=a;
if (b<0) then b1:=b;
if (c<0) then c1:=c;
if (d<0) then d1:=d;
writeln ('Произведение отрицательных = ',a1*b1*c1*d1);
end
else writeln ('Все числа больше либо равны 0');
end.

Ответить

Другие вопросы из категории

помогите составить блок-схему и программу паскаль

Cоставить программу, сообщающую о возможности
построения параллелограмма из отрезков X,Y,Z,T
Данные
1 , 2 , 1 , 2 можно
7 , 5 , 6 , 5 нельзя
Пожалуйста
Срочно
Надо

ИЩИТЕ ВЕЗДЕ!!!! ПОЖАЛУСТА!!! срочо
Программой архиватором называют:

1) Программу для рабоы с эл. таблицами
2) Систему управления базами данных
3)Программу резервного копирования файлов
4) Программу для сжатия файлов

Читайте также

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);

Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В и С. Если они не равны, то замените все числа

наибольшим из них и выведите результаты на экран. Иначе, найдите и выведите сумму квадратов этих чисел.

Напишите программу, которая находит произведение двух наибольших чисел из последовательности натуральных чисел. Программа получает на вход натуральные

числа, количество чисел неизвестно (но не менее двух), ввод последовательности заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Значения чисел не превышают 30000. Программа должна вывести одно число: произведение двух чисел, значения которых в данной последовательности наибольшие

1)Определить если в

составе двухзначного
числа одинаковые цифры.
2)Вводятся 2 числа одного
ли они знака?
3)Вводиться двухзначное
число, посчитать
произведение чисел.
4)Принадлежит ли х
отрезку 1.5?
5)является ли ввод с
порядковым номером у
высокосным или нет
6)Вводиться 4 числа,
посчитать сумму
произведений
отрицательных чисел.
7)Вводиться 5 чисел найти
сумму чисел меньше 3, и
произведение чисел
больше 5.
8)Вводиться число
определить его знак.
9)Вводиться 6 чисел найти
сумму произведений тех
из них которые больше 10.



Вы находитесь на странице вопроса "Введите с клавиатуры четыре числа. Найдите и выведите н экран сумму и произведение тех чисел, значения которых отрицательны.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.