Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Начав тренировки, лыжник в первый день пробегал 10 км.

1-4 класс

В каждый следующий день он увеличивал длину пробега на 10% от предыдущего дня. Определить, в какой день он пробежит 20 км.

Составить программу в паскале.

(Оператор Цикл. Цикл с предусловием.)

AliceFrainer 22 сент. 2016 г., 3:46:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КапитоШка55555
22 сент. 2016 г., 4:51:34 (7 лет назад)

Вариант номер 1:
 
program c1ba;
var a:byte;   
p:real;
begin
p:=10;
a:=1;

repeat begin
p:=p+(p/10);
a:=a+1;
end;
until p>=20;

writeln('a=',a);
end.


Вариант номер 2:
program c1ba;
var a:byte;   
p:real;
begin
p:=10;
a:=1;
while p<=20 do begin
p:=p+(p/10);
a:=a+1;
end;

writeln('a=',a);
end.

Ответить

Читайте также

Артур взяла у Антона книгу на три дня.В первый день он прочитал 1/2 книги,во второй-1/3 оставшихся страниц,а количество страниц,прочитанных в третий

день,было равно половине страниц,прочитанных в первые два дня.Успел ли Артур прочитать книгу?Попробуйте пожалуйста решить если в книге 120 страниц

Хитрая Кикимора решила в отсутствие Змея Горыныча разыскать спрятанный им клад. Для этого Кикимора должна за 3 дня успеть найти владения Змея Горыныча

и обследовать 4 пещеры. За первый день она может найти владения Змея Горыныча, за второй день она сможет обследовать первую или вторую пещеру. Нарисуйте «Дерево решений» и найдите, сколько разных вариантов есть у Кикиморы, чтобы найти владения Змея Горыныча и обследовать пещеры, если за третий день она сможет обследовать только одну пещеру из оставшихся. Успеет ли Кикимора обследовать все пещеры за 3 дня?

Во время каникул веселые человечки отправились путешествовать на разных видах транспорта. Незнайка проплыл 50 км на пароходе, проехал 40 км на

поезде и пролетел 100 км на самолете. Поэт Цветик проплыл на пароходе 100 км и проехал на поезде 20 км. Торопыжка пролетел на самолете 200 км и проехал поездом 10 км. Доктор Медуница проехала на поезде 30 км и проплыла на пароходе 60 км. Стоимость проезда на поезде составляет 1 монету за км, на пароходе – 2 монеты за км, на самолете – 4 монеты за км.

Построить электронную таблицу, из которой будет видно: какое расстояние проехал каждый из человечков и сколько денег он заплатил за дорогу; какое расстояние все человечки вместе проехали на каждом виде транспорта и сколько им стоило; сколько денег все человечки вместе заплатили за все виды транспорта.

ПОМОГИТЕ!!!

посмотри что получается если выполнить команды для чисел 10 и 22 допиши команды алгоритма и выполни команды для чисел 8 и 30 и следущие задание к нему

же 1) начало 2) запиши число 3) вычти если полученное число меньше 10 то 5) прибавь иначе 6) вычти 7) прибавь 8) конец



Вы находитесь на странице вопроса "Начав тренировки, лыжник в первый день пробегал 10 км.", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.