Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

почему в информатике используются двоичная, восьмеричная,шестнадцатеричная системы счисления

10-11 класс

Zyablitskiy00 25 окт. 2013 г., 11:44:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Алена9614
25 окт. 2013 г., 13:14:10 (10 лет назад)

система счисления - это система счета (сколько цифр используется)
те, что применяются: десятичная в математике, двоичная, восьмеричная, шестнадцатиричная в информатике и ПК

Ответить

Другие вопросы из категории

Прошу решить,заранее спасибо
№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

В алфавите племени МУМУ всего 4 буквы (А, У, М, К), один знак препинания (точка) и для разделения слов используется пробел. Подсчитали, что в популярном

романе «Мумука» содержится всего 10000 знаков, из них: букв А - 4000, букв У - 1000, букв М - 2000, букв К - 1500, точек -500, пробелов - 1000. Какое количество информации содержит книга?

Читайте также

• Перевести данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления:


1) 164.25
2) 520,375

• Перевести данное число в десятичную систему счисления:
1) 1110010100,1011001 (двоичная СС)
2) 1000000110,00101 (двоичная СС)
3) 666,16 (восьмеричная СС)
4) 1C7,68 (шестнадцатеричная СС)
*СС - система счисления.

СРОЧНО! ПОМОГИ! ПОЖАЛУЙСТА!!!!!! №1. В системе счисления с некоторым основанием десятичное число 43 записывается в виде «111». Укажите это

основание

№2. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись десятичного числа 53 оканчивается на 3.

№3. Укажите через запятую в порядке возрастания все числа, не превосходящие 30, запись которых в двоичной системе счисления оканчивается на «101». Числа в ответе указывайте в десятичной системе счисления.

№4. Количество единиц в двоичной записи числа 12, 25 равно…

№5. Для кодирования букв А,Б,В,Г решили использовать двухразрядные последовательные двоичные числа (от 00 до 11 соответственно). Если таким образом закодировать последовательность символов ГБАВ и перевести результат в шестнадцатеричную систему счисления, то получится…

№6. Как представляется десятичное число 13,5 в двоичной системе счисления?

№7. Как представляется десятичное число 416 в восьмеричной системе счисления?

№8. Как представляется десятичное число 523 в шестнадцатеричной системе счисления?

№9. Вычислите значение суммы 1012 + 118 + 1016. Результат представьте в виде десятичного числа.

№10. Вычислите значение разности двух чисел 1116 – 118. Результат представьте в виде десятичного числа.

Даны системы счисления с основаниями 2, 8, 10 и 16. Запись вида 328! а - отсутствует в восьмеричной системе счисления, б - существует во всех

перечисленных видах счисления, в - отсутствует в шестнадцатеричной системе счисления, г - отсутствует в десятичной системе счисления, д - существует в двоичной системе счисления

5. Системы счисления.

a. Переведите данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления: 114,22510
b. Переведите данные числа в десятичную систему счисления:
100111100,11012
1234,58
2B3,F416
c. Сложите числа:
1001100111,112 + 100001101,1012
272,348 + 1567,28
65,216 + ЗСА,716
d. Выполните вычитание:
1110110110,00112 – 11111110,012
1360,148 – 1216,48
ЗЗВ,616 – 11В,416

e. Выполните умножение
111,1012*1012
124,38*378
1А416*F316
6. В системе счисления с некоторым основанием десятичное число 49 записывается в виде 100. Укажите это основание.



Вы находитесь на странице вопроса "почему в информатике используются двоичная, восьмеричная,шестнадцатеричная системы счисления", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.