Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана матрица 8 на 5, заполненная случайными числами от 0 до 10.Нужно вывести на экран исходную матрицу и матрицу, в которой к третьему столбцу добавл

10-11 класс

ен шестой.

Lidiya123 03 мая 2015 г., 19:40:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Silysha2001
03 мая 2015 г., 22:16:26 (9 лет назад)

var
  i,j,k:integer;
  a:array[1..5,1..8]of integer;
begin
writeln('Исходная матрица:');
for i:=1 to 5 do
  begin
  for j:=1 to 8 do
    begin
    a[i,j]:=random(11);
    write(a[i,j]:3);
    end;
  writeln;
  end;
writeln('Преобразованная матрица:');
for i:=1 to 5 do
  begin
  for j:=1 to 8 do
    begin
    if j=3 then a[i,3]:=a[i,3]+a[i,6];
    write(a[i,j]:3);
    end;
  writeln;
  end;
end.

+ 0 -
Valu05
04 мая 2015 г., 1:09:39 (9 лет назад)

Язык?

+ 0 -
Kirillkirchak
04 мая 2015 г., 3:34:11 (9 лет назад)

паскаль

Ответить

Другие вопросы из категории

В задаче на двумерный массив сделать файловый вывод. Вот само решение задачи.

var a:array[1..12,1..10] of integer;
i,j:integer;
begin
for i:=1 to 10 do
a[1,i]:=i*12;
for i:=2 to 12 do
for j:=1 to 10 do
a[i,j]:=a[i-1,j]-1;
for i:=1 to 12 do begin
for j:=1 to 10 do
write(a[i,j]:4);
writeln;
end;
end.

Решите в паскале ABC .

Известно время полета вылета самолета - HH часов и ММ
минут, а также продолжительность полета (НР часов и МР минут). Напечатать время
прибытия самолета в аэропорт назначения в виде: самолет прибывает в
12.35. Учесть возможность перехода часов (после 23.59 наступает 00.00).

Для передачи по каналу связи сообщения, состоящего только из символов А, Б, В и Г, используется посимвольное кодирование: А – 00, Б – 11, В – 010, Г –

011. Через канал связи передаётся сообщение: ВБГАГВ.Закодируйте сообщение данным кодом. Полученное двоичное число переведите в шестнадцатеричный вид.

Читайте также

1.Одномерный массив заполнен случайным образом. Найти количество четных элементов. 2. Одномерный массив размерностью N , где N -нечетное число,

заполнен случайными числами от -15 до 6. Все , числа кратные 3 заменить на противоположные.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.



Вы находитесь на странице вопроса "Дана матрица 8 на 5, заполненная случайными числами от 0 до 10.Нужно вывести на экран исходную матрицу и матрицу, в которой к третьему столбцу добавл", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.