Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Паскаль.

10-11 класс

Нужно написать программу, которая высчитывает среднею температуру, максимальную и минимальную температуру за месяц.
Вот, пытался написать сам, не получается:
program PoGoda;
uses crt;
var
x, n, t : integer;
max, min, imax, imin : integer;
const z=5;
begin
for x := 0 to z do;
x :=1;
while (x < z+1)do
begin {Создаем массив}
while (x > z) do
writeln;
write ('Какая температура была в ');
write ( x);
write (' день? ');
readln (t);
inc (x);
end;
max:= t[x];
for x:=0 to z do
if max begin
max:=t;
imax:=x
end
else
if min>t then
begin
min:=t;
imin:=x
end;
writeln;
writeln('Максимальное значение ',max);
writeln('В какой день месяца было максимальное значение ',imax);
writeln('Минимальное значение ',min);
writeln('В какой день месяца было минимальное значение ',imin);


readkey;
end.


NecroAsh 19 авг. 2014 г., 15:48:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zhasmin18042007
19 авг. 2014 г., 16:45:43 (9 лет назад)

Готово........................

Ответить

Другие вопросы из категории

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.