Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано число. Найти его наибольшую цифру. Язык - Си. 8 класс, самые основы инфы. СРОЧНО!

5-9 класс

алина78 15 июля 2013 г., 3:49:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
12332211
15 июля 2013 г., 4:27:46 (10 лет назад)

#include <stdio.h>


int main()
{
int max, n, i;

scanf ("%d", &n);

max = n % 10;

while (n > 0)
{
if (max < n % 10) max = n % 10;
n = n / 10;
}

printf ("%d", max);

getchar ();

return 0;
}

Ответить

Другие вопросы из категории

Градиентом в графическом редакторе называют..

а) заливку одним цветом
б) сложный геометрический узор
в) растровую текстуру
г) плавный переход одних цветов в другие

1)составьте программу ввода элементов массива а[1..8 ] с клавиатуры и вывода на экран элементов с отрицательными значениями; 2)составьте

программу ввода элементов массива b[1..6] с клавиатуры и вывода на экран элементов с положительными значемиями

Ответьте на вопросы:Устройство вывода информации?Устройство хранения программ и данных?Устройство ввода ,используемое во времч игры?Другое название

жёсткоао диска?Устройство с помощью которого можно вывести на бумагу тексты и рисунки?

Читайте также

Ребятки!!!!ПОмогите пожалуйста очень срочно!!!! Дан файл f компоненты которого действительные числа.Найти сумму компонентов

файла.Результат поместить в файл g.

дан файл f компоненты которого являются целыми числамию Найти наибольший и наименьший из компонентов файла.результат поместить в файл g

ДАн файл f компоненты которого являются целыми числами найти количество чётных чисел среди компонентов.результат поместить в файл g

Дан файл F компоненты которого являяются целыми числами.записать в файл g все чётных числа файла f

Дан файл F компоненты которого являяются целыми числами переписать компоненты файла f в файл g,так чтобы в файле сначала шли отрицательные а потом положительные числа.

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2

В трехзначном числе x зачеркнули его вторую цифру. Когда к

образовавшемуся двухзначному числу справа приписали вторую цифру числа x, то получилось число n. По заданному n найти число x
(значение n вводится с клавиатуры).



Вы находитесь на странице вопроса "Дано число. Найти его наибольшую цифру. Язык - Си. 8 класс, самые основы инфы. СРОЧНО!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.