Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале. P.S формулы в программе быть не

5-9 класс

должно

Akexeencom 21 дек. 2013 г., 20:55:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lsultanghali03
21 дек. 2013 г., 23:16:04 (10 лет назад)

var a:string;
i:integer;
c:boolean;
begin
readln(a);
repeat
if pos('+',a)<>0 then begin inc(i); delete(a,pos('+',a),1); end;
if pos('-',a)<>0 then begin inc(i); delete(a,pos('-',a),1); end;
if (pos('+',a)=0) and (pos('-',a)=0) then c:=true;
until c;
writeln(i);
end.

Ответить

Другие вопросы из категории

помогите пож-а))) 5. Есть исполнитель «Арифмометр», который понимает следующие команды: - взять число N

(занести в память число N),

- умножить (перемножаются занесённые в память последние два числа),

- сложить (складываются занесённые в память последние два числа),

- вычесть (вычисляется разность занесенных в память последних двух чисел),

- результат (вывести результат)

Например, в результате выполнения алгоритма:

- взять число 5,

- взять число 10,

- взять число 2,

- вычесть,

- умножить,

- результат

получим ответ 40, так как 5*(10-2)=40.

Какой результат будет получен при выполнении приведённого ниже алгоритма?

- взять число 4,

- взять число 8,

- взять число 2,

- вычесть,

- взять число 10,

- умножить,

- взять число 56,

B 2 В про­грам­ме «:=» обо­зна­ча­ет опе­ра­тор при­сва­и­ва­ния, знаки «+», «-», «*» и «/» — со­от­вет­ствен­но опе­ра­ции сло­же­ния,

вы­чи­та­ния, умно­же­ния и де­ле­ния. Пра­ви­ла вы­пол­не­ния опе­ра­ций и по­ря­док дей­ствий со­от­вет­ству­ют пра­ви­лам ариф­ме­ти­ки. Опре­де­ли­те зна­че­ние пе­ре­мен­ной a после вы­пол­не­ния ал­го­рит­ма:

Читайте также

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них



Вы находитесь на странице вопроса "Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале. P.S формулы в программе быть не", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.